Adjust Yaw rotation speed and smothness in wp missions with user controlled heading

I have the same hand tremor issue so Litchi is critical to me getting smooth video with my Air 2S. Using the same waypoint mission I get jerky yaw movements with Air 2S but buttery smooth with my Mavic 2 Pro and Zoom.
Hope this gets resolved :slight_smile:

Thanks for the information, I will look at that.
Seems a bit of a long and clunky journey to put a mission together.

What mission improvements does Maven have that Litchi does not ?

However, Maven only works on an Apple Mac, not a windows PC.
I am not going to struggle to make a mission on on a tiny Ipad screen
when it is much easier for me to make Litchi missions on my 32" PC screen.

From what Maven claims, actions work on curved missions. Right now with Litchi, you have to plan straight waypoints and it stops at each waypoint, regardless if there are actions added. To me that sucks. I will purchase it soon and see how it goes. Plus there are “a lot” more cool features like zip line.

When you are referring to Apple/ PC, I’m assuming you mean IOS vs Android? Not sure how long they will take to get the android version going. But they moved pretty quick on the IOS version.

I plan my missions on a pc with Litchi mission hub and plan to upload to my iPhone. Hope this helps…

1 Like

Thanks everyone for trying to find a solution to the jerky yaw movements in drones using the virtual sticks implementation in Litchi.

I have been flying Litchi missions using a M2Z (onboard waypoints) for years with absolutely wonderful results. However, as most everyone knows, flying the same missions using an A2S (virtual sticks) results in jerky yaw movements.

I have begun tweaking parameters to see if there is a combination of settings that smooths out the A2S. I’ve tried normal, sparsely places waypoints with curved turns. I’ve tried missions with many, closely placed waypoints (and curved turns) and the results are the same. I have more ideas to try when the weather improves and will report back if I find anything that improves the smoothness.

4 Likes

I have performed a number of experiments using Litchi and an Air 2s trying to obtain a smooth yaw movement as the drone proceeds through its mission. The first was a mission with a reasonable number of waypoints, one POI and the curve size set to 1/2 the distance between waypoints which results in a perfectly smooth circle:
junk
As you might have guessed, this did not result an a smooth yaw movement.

Next, I tried a similar mission with many waypoints. I got the same result:

Third, I removing the curved turns, using straight paths between each waypoint. Unfortunately, I experienced the same result.

All missions were flown at a slow 5 mph. If there is a way to smooth the yaw movement, I have not yet found it.

Again, with my M2Z (on-board waypoints), the yaw movement is perfectly smooth.

3 Likes

So I’m new here just trying to learn more about Litchi before buying it. I’ve seen many complaints about lack of smooth movements in waypoints mode for the air2s (my drone). However, are these movements smooth in Orbit mode about a POI? Forgive my ignorance (or irrelevance to the discussion at hand), but I just wanted to know.

Say the track and follow modes always worked as virtual sticks on all drones, but there were no jerks. Does this mean that jerks are a software bug in new versions of litchi.

The jerky yaw motion is not a bug in Litchi. Instead, it is a limitation in what controls DJI provides in their SDK. A good explanation is given here:

Yes, and it seems the sdk made a mistake in the new update. After all, other drones used to fly with virtual sticks on follow modes, but there were no jerks, I think other drones will also have problems with new versions of litchi.

Hi there,
I’ve been down the path of Air 2 with virtual joysticks and decided to purchase a M2E (Zoom) and I am experiencing the same yaw jerkiness. Here is a video sample:

Can you tell me if you ever experienced the jerkiness on YOUR M2 Zoom and how you may have adjusted it? Any insight you can provide is really appreciated. My Mavic Air has produced amazing footage with Litchi Waypoints and I can’t get my Air 2 or M2E to come close to that.

You can email me directly if you want....derwinmichael@gmail.com.

Thanks!

@michaelderwin
Enterprise drones (M300 RTK, M2EA, etc) have some level of support but are not officially supported and tested.

As I speculated in another thread, the smoothing algorithms are in the drones, not the RC (at least for my Mine 2). If you think about it, their parameters are set only when the drone is connected, and they are grouped with other parameters that are clearly in the drone. Both DJI Fly and Litchi send their yaw commands at a certain frame rate (let’s say it’s every 1/2 second). Yaw commands sent are jerky for both. The fact that DJI put smoothing algorithms in the drones proves that. But the drone firmware sends the DJI commands through the smoothing algorithms, but I’ll bet the Litchi commands do not go through the algorithms. Probably because the public API that DJI published did not include access to the smoothing algorithms, presumably by intent. Part of DJI’s secret sauce.

So unless DJI provides that access, any second party software will be hamstrung by the same problem: jerky commands most visible in yaw sweeps (but also visible in gimble motion).

This is the result of my latest testing. Please check out the settings clip for both the Air 2S and the Litchi waypoint setting.
Waypoint Flying Test

Thanks, Rex. I watched the video you provided. My problem is uneven speed in Litchi WAYPOINTs, even when all waypoint nodes are set to ‘cruising’… it seems that the drone will come to a complete stop at random waypoints before resuming back to cruise speed. (I have an Air 2S running Litchi on a small iPad.) This makes Litchi WAYPOINTs almost useless for my use cases.

1 Like

I have the exact same problem with my Air 2S. But on Maven as well. Looks like a bug in the sdk

I have an Air 2s and use an iPad Mini 5. I don’t experience the drone coming to a complete stop or changing speed at waypoints (unless I configure it to do so). If the cause was a bug in the SDK, shouldn’t I also experience this behavior?

The only time the drone would come to a stop at waypoints is if your curve size at that waypoint is set to zero. Do all of your waypoints have a non-zero curve size (and therefore, a curve)?

1 Like

Thanks again @wesbarris for taking the time to check out this issue which is affecting so many of us. I had some interesting “extra” movements of the gimble with a Mini SE that definitely were not in the VLM, but I didn’t know if it was fixable. Buying a drone with internal memory like the M2 Pro/Zoom definitely sounds best for serious photography!.