Adjust Yaw rotation speed and smothness in wp missions with user controlled heading

Nothing wrong with the DJI Go4.

I didn’t say it was bad.

You are forgiven😉. The point is Litchi waypoints mode runs the M2Pro perfectly. Smooth, accurate and fully autonomous. I only wish I had kept it.

1 Like

And not only on m2pro. Also pro1, air and spark do a great job of waypoint mode. They also have obstacle avoidance sensors.

I did not write that the Mavic 2 Pro is controlled by Virtual stick Commands.
I wrote about the much larger mass of the Mavic Pro 2 will help to damp out
any tendency to twitch about the vertical yaw axis when turning.

It still is not the reason for this problem, and that’s what you actually wrote.

OK, you win… What is the reason for this problem ?
.

Virtual Stick Commands.

Every 10th of a second (I believe it is) Litchi sends a controll signal with tasks to the drone, so the drone knows what to do, then the drone sends a feedback signal to litchi, so litchi knows if the drone executed these tasks and were executed correctly, and Litchi can workd out the next set of tasks to send.

When either of these signals do not arive at their destination, even for 1/10 of a second, trouble starts.

Have a look at this video (starting at 2:30)

2 Likes

Yep … That’s a really good explaination of the problem :grinning:

I am wondering if using the Maven app will improve the stability …

.

That looks interesting but not on Android

But it also twitches

Maven does not seem to have a mission hub to use on the PC,
similar to Litchi, so that’s a NO from me . . :anguished:

What scares you to create missions on your phone in litchi

It’s just so much easier to do in mission hub, plus you don’t get to be where you are going to fly the mission, I’ve planned missions in France in the hub while sitting in flat in England, that would take a lot of doing in the app

1 Like

I have a physical condition that results in a pretty significant hand tremor, so my stick commands are very choppy, at best. And yet, when I’m flying in manual mode, my Mini 2 turns very smoothly. I think this happens because the firmware in the drone takes my choppy commands and passes them through a smoothing filter of some sort (probably a PID filter), and the output of that filter is what the drone responds to. So I think you are exactly right; the jerks in waypoint mode are due to choppy and sometimes interrupted commands being sent by the litchi app, and I’ll bet they are not being passed through the smoothing filter before being sent on to control the drone. As I said above, the API that DJI provided litchi may not include access to the smoothing filter, so the drone is responding to choppy commands. If those smoothing algorithms are available in the API, then litchi should correct this. If they are not, then it’s beyond their control to correct this.

As I said in my previous post, I have a hand tremor that makes fine detail touch-screen input, like on an iPhone, very difficult. That’s why I fly with an iPad. But even then, I’m much better with a mouse on a PC, and I have a nice large 4K monitor to see the big picture. I do occasionally change a parameter, like Cruising Speed, using the iPad screen when I’m out flying somewhere, but it’s difficult.

And I did do some flight test to examine ways to minimize, and the results are posted here:

archer…i read on the Maven website that you can use Litchi’s mission hub to plan and export it as a CSV. Then upload it in the Maven app. Check out their website.