Take photo only on interval without waypoints

I am using Litchi for photogrametry.
I create my plans using AgiSoft, globalmapper, Civil 3D and excel.
First from the previous flight I export a DEM from AgiSoft.
Unfrotnally AgiSoft can’t export it in the format (degrees) which Litchi requre.
Then import the DEM in GlobalMapper to export the asc file.
In Civil 3D I create polyline for my flight route. Export it as kml and then import it in Litchi.
Unfortnally when import it the litchi double every waypoint.
So I download it as csv and in excel delete the repeat waypoint.
Also in excel I set the height, gimble pitch and using DEM elevation.
I am using waypoint in 40x40 m. mesh, so the drone can follow the terein.
Now I am using Mavic Pro 1 and picture in every 40 m is OK for my projects.
But know have idea to upgrade. When I choose a new drone I will be able to incrase the distance between photos, becuase of the better footprint.
This means I should change the size of the mesh to 60x60.
But then I am losing elevation data and the drone will not follow the terraing precise enough to have same GSD.
It will be super if I can set up the waypoints in every 40 m. but the drone take photo only when travel 60 m from the last pictures.

You can already do this. In the Mission Settings, you can choose a photo be taken every ‘x’ seconds or every ‘x’ feet (or meters).
See the Photo Capture Interval


I know this and use it.But the drone (Mavic Pro 1) take photo on every waypoint.
I have waypoint on every 40 m.
When I setp up the photo capture interval - 30 m,
-the drone fly 30 m. from waypoint 1.

  • take photo
  • fly 10 m to waypoint 2
  • take photo
  • fly 3 m from waypoint 2
  • take photo
  • fly 10 m. to waypoint 3
  • take photo

Do you have waypoints actions set up at each waypoint?

If you would like to share the mission thats giving you problems, people here will be glad to have a look.
In case you arent familiar with how to share a mission, here is some info:

Change the path mode from straight lines to curved turnes, and photo capture interval to 60m.
Then the drone does not stop at each waypoint and waypoint actions will be ignored.

The mode is already curved, and the drone doesn’t stop at waypoint.
Just take e photo.

I don’t have set up action at waypoint.
Here is one of the plan.

Hi. I’m no expert on this but I have to ask. Are you taking the photos manually as the drone flys the mission? If not then you NEED to set an action to tell it to take photos. Unless there’s another way to do it that I’m not aware of…


The mission you shared has actually a 50x40m grid/mash, not 40x40m.
It will take a photo every 40m because you have set a Photo Capture Interval of 40m.

The Mavic Pro has a FOV of 78.8° diagonal.
This results in a vertical FOV of 52.5° or 78.9m at 80m high,
and a horizontal FOV of 66.6° or 105.1m at 80m high.
Your grid is based on a 50% overlap.

The DJI drone with the biggest FOV is the Phantom 3 Pro (94° diagonal).
The next best upgrade would be the Air 2 S (88° diagonal).
The vertical FOV difference of the Air 2 S compared to the Mavic Pro at a hight of 80m is only 13.8m, NOT 20m.

When using your shared mission with an Air 2 S you could increase the Photo Capture Interval from 40m to 47m to keep the 50% overlap (92.7m/2=46.5m or 40m+13.8m/2=46.9m).

Also have a look at this thread:

The size of the mesh is not important.
The shared mission is a test of new settings.
I always made double grid, so I can increse the photo interval and get enough overlap.

The problem is that there is not set any action on the waypoint, but the drone take a photo.

Read the second line of my previous post again !

Read the lines from my fisrt reply :wink:
When I setup up the photo capture interval - 30 m,
-the drone fly 30 m. from waypoint 1.

  • take photo
  • fly 10 m to waypoint 2
  • take photo
  • fly 30 m from waypoint 2
  • take photo
  • fly 10 m. to waypoint 3
  • take photo

That’s because your waypoints are 40m apart AND you have set an interval of 30m at EACH waypoint, this means the count of 30m will start over and over again at each waypoint.

Disable ALL interval settings at ALL waypoints except for the waypoints at the corners (2, 8, 10, 20, 21, …)

Interesting! I wasn’t aware that setting the Capture Interval would cause the drone to auto take photos based on that interval. I thought you needed to set an action to have it take photos.

Every day’s a school day!

Looks like a complicated subject and one which I’d like to know more about and understand. A video tutorial showing a couple of flights with different FOV’s might be of help. I may go search YouTube to see if there is one available.

That would be useless because the FOV’s between DJI drones do not differ that much, except for the Mavic 2 Zoom and the ones with more than 1 camera.

The Interval setting at the waypoint is only showing the Interval that is set in the Mission Settings. Thats why it has the ‘pencil’ image and the interval number is greyed out. You can customize each waypoint interval, but it will always show a number (or distance).

@Marin1 ,
Your intermediate waypoints along the vertical lines are useless. They are messing up your interval (TriBar pointed out). The interval will restart at each waypoint. That info is in the Litchi Help.

My suggestion is this:
Eliminate all of the waypoints except your turn points. It will give you more consistent photo capture intervals because of the longer travel distances.
Here is a modified mission.

Read my first reply here (2nd post of the thread).

I can’t delete the middle waypoint, because they give diffrent alltitude. This how I follow the terrain and maintain 80 m. above ground.

Good point. I didnt look at it in 3D. Looks like you’ll have to live with extra photos.