Air 2S Waypoints and POI

Just bought Litchi and am loving it but have an issue I need help with please.

I set up a mission with 5 waypoints to fly across and back over a bridge. I set the POI to be the bridge. When I fly the mission with the Mini 2 it executes flawlessly …moving from one point to the other with the bridge constantly being filmed. The Mini 2 mission does have curved turns.

I adjusted the mission for the Air 2S to be straight lines and disabled the obstacle avoidance so the drone can fly sideways. Each waypoint is also set for the bridge to be the POI. When I fly the mission the drone moves to the first waypoint and faces the camera straight down to the ground and then moves on to each waypoint. It never points the camera to the bridge.

Is there a setting I am missing ?

Waypoint Missions are drone independent.
The only thing you needed to do in the Mini-2 mission was to set Path Mode in Mission Settings to ‘Straight Lines’, that’s it.

Could you share the mission?

Instructions here:

Thanks TriBar

Here is the link : Mission Hub - Litchi

Yeah, I’m having the same problem with the air2 s the gimbal indicated on the app does not show the pitch moving even!!! there is a bug!!! the workaround is to disable pitch control in the missions and move your pitch with the wheel as you fly by waypoints on the controller!!!

1 Like

4.22 and a new drone firmware have been released especially for you

1 Like

Have a look at this topic:

Also keep an eye on:
What’s New:

Known Issues:

Thanks William – will give that a try :slight_smile:

I hope so!! I love what it can do

Thanks TriBar — will keep you posted on what I find out

Downloaded the new update for the Air 2S and the Mini 2 and went and tried it today. The Air 2S did exactly what it was supposed to — Yay!!! The update worked

Thanks everybody for all your input — much appreciated :slight_smile:


So is litchi fully working now with the Air2S?

I only used waypoints – not any of the other functions — worked just fine with that

1 Like

what controller are you using… I have a RC Pro and I’m getting disconnected error in red across the top of the controller… if I push the record button it says Camera not connected… thanks in advance for any help…

This is a message that the drone is not connected.

The RC Pro is not yet supported in the DJI SDK, so it will not work with Litchi until DJI updates the SDK with RC Pro support: DJI Monitors (Smart Controller, CrystalSky, Phantom 4 Screens) - Litchi

ok got it thanks for the quick reply