Waypoints: Manual increasing speed between waypoints doesn't work

Hello All,
few days ago I did some flights with my DJI Mavic Mini. Everything works like expected, except manual changing speed between 2 waypoints with the controllers right joystick (mode 2). The Mavic Mini doesn’t change speed, even if I put the stick to any direction (top, bottom).

Sample:

  • Waypoint mission with 5 waypoints
  • General settings: cruising speed: 15 km/h | max speed: 35 km/h
  • For all 5 waypoints: Speed = used cruising speed

What I want to do is: If during my waypoint mission an interesting object occurs, then I want to in- decrease for a short time the missions speed to get the object within the focus. Later on the mission should be continued with the programmed cruising speed.
Litchi help shows:
Max Flight Speed: If you use the remote controller’s right joystick (mode 2) while the mission is in progress, you can increase the speed of the aircraft up to the “Max Flight Speed”.

But like already written, moving the stick doesn’t change anything of the speed.

Am I doing something wrong? Any hint is appreciated.

Greetings from Germany
-Klaus-

This feature does not work (yet) with drones that use the DJI FLY App.

@TriBar: Thanks for your comment, but I don’t see any relation between the Litchi and the DJI Fly App.
If Litchi is active, then DJI Fly is not active, so the DJI Fly app has nothing to do with Litchi.
Furthermore I learned, that Litchi does a realtime calculation of the flight of the waypoint mission; means every point of the waypoint mission is calculated. So it should be easy to de-increase the speed of the drone during this mission.

It is not supported yet but we hope to add support for it soon

1 Like

Drones built for the DJI FLY App (Mavic Mini & newer) are controlled using “Virtual Stick Commands” which are send to the drone continously by the remote controller.
This is a very different aproach as formerly where the mission is uploaded to the drone and the drone does (almost) everything by itself. You can even turn off the controller and the mission will be completed. With these newer drones you can’t, Every disconnect between the aircraft and the controller, even miliseconds, means 1 or more specific control-command(s) will not be executed until connection is re-established again. When the disconnect takes too long, RTH will be executed.

I’m very disappointed DJI went this way !

@vico: Thanks for the info
@TriBar: Thanks for the explanation

Thanks that is really interesting! However it is possible to manually vary speed when in Orbit mode.

I’ve been begging Litchi to enable this function!

1 Like

Have you tried manual speed control according to this youtube video?

urkman, this works only for drones, which are NOT controlled via DJIs Fly app (virtual joysticks).

For Gimbal Pitch changes and Flying Speed Changes to work there MUST be a connection between the AC and RC.
Manual speed override for drones build for the DJI FLY App (Mini-1 and newer) is NOT yet available in Litchi.

1 Like

I really hope Litchi adds this feature for virtual stick controls. I would get a lot of use of of the “cable cam” waypoint type setup if I could manually control speed and gimbal without having to worry about wandering from the preprogrammed flight path.

Tutorial DJI Drone Litchi Waypoint Mission Cable Cam

@Emilio1
It looks like you are able to control speed of a waypoint mission.
Today I did a further test, but I’m still not able to change speed between the waypoints.
My config:

  • DJI Mavic Mini
  • Android mobile phone
  • Litchi V 4.25.0-g

Possibly you have an other config, with which this feature is working?
See also the comment of TriBar above.

The ability to vary the speed during a mission is only available on the older drones that actually upload the waypoints to the aircraft. The newer, DJI Fly drones do not have this feature.

Maybe it’s a issue of DJI FLy drones. I knew ,that they abort the mission if the sign is lost. But (I think) I remenber to change the the speed of the Mini2 using the right stick. I sold the Mini2 and can’t test this.

I did a “blind” (with no sign) mission with the Mavic2Pro and it did perform different speeds at each waypoint.

Choose automatic translation in your language from the esperanto subtitles. In esperanto each word has only one meaning, so it´s better for automatic translations.