Waypoint mode - gimbal on Air 2s not following along

I’ve seen a few posting with similar issues but no resolution…

Waypoints seems to be 100% correct on a route with 6 points. Google Earth KML plays back nicely. But gimbal has a life of its own when I go shoot. Sometimes it’s stuck at -90, sometimes it seems to get through 3 waypoints correctly before going to -90. No issues with the drone using DJI app (other than severe limitations!).

All waypoints have gimbal pitch set to interpolate. #1 and #6 have POI’s selected in popup (but interpolate is selected not Focus POI). Gimbal pitch it set between -50 and -10 on the various waypoints. None of them are -90.

Was excited about Litchi but not liking the controls so far. I have a motion graphics background, wish I could just keyframe waypoints, and separately keyframe gimbal (camera…).

is the Drone firmware completely up to date

The “Interpolate” setting refers to, and controls, the gimbal pitch angle. Selecting a POI refers to, and controls, the heading. Generally, when specifying a POI for the heading, you also want the gimbal pitch angle to focus (vertically) on that POI.

I fly an Air 2s and don’t experience this behavior. Would you be willing to share your mission by unchecking the “Private” checkbox and copying and pasting the URL here?

Everything is up to date. thx

I’m going to run a few more tests, thanks for your input!

Simplified the missions and tried again. But the drone shot with gimbal at -90 the entire time.

Created one that where gimbal is set to a few different POI (all WPs are set to 1 of 2 POIs):

And one where gimbal is set to interpolate throughout with WP1 @ -50 and the next 5 are set between 0 to -20:

Did I miss something obvious?

1 Like

No, you didn’t miss anything obvious. While I could make some suggestions about your missions, there is nothing in them that would cause a -90 degree gimbal pitch angle. Therefore, something else is causing this.

Did you “force-close” DJI Fly before running Litchi?
Are you located really close to this mission while flying it?

I did force quit the DJI app. And I’m no further than 250 yards from the drone at any time. Is there a chance I missed something and the app isn’t set up for the Air 2s, its defaulting to a different drone (with different gimbal coding)? At a loss…

Force-closing the DJI app is important because, if running/suspended in the background, it can still prevent Litchi from operating correctly. You said that you have “force-closed” (not just closed) it. So that shouldn’t be the problem. You are close enough so that signal issues shouldn’t be the problem.

The gimbal rotating to -90 is normal when landing, but you say it is happening during a mission. I am at a loss. I haven’t heard of this problem before. You said that you found posts with similar issues. Can you point me toward one?

Do you have the video you could share?


Here you go:

Here’s another thread that seems to have similar issue, but no resolution:

Thanks, which mission is it that you shared, I’m having trouble with one of them when I try to send it from VLM to GEP.


Edit I see this coming from drop box, I’m trying to downloaded right now.

This was the one where all WPs had POI selected throughout. Thank you

I watched the video, I keep getting errors, to VLM and to Google Earth, I will get back later…


I figured out why VLM was creating errors. Don’t put an * in the begging of the filename. Everything works except the last part.

So, you got any other missions you have tried?
From my missions I have ran at least 40+, I don’t think it is a Litchi problem.

I got many ideas I’m thinking of, until I get some more from you, I will be waiting.

Closing DJI, etc, using an android yes…There use to be an app to do that. I think it was appkiller?
I feel like something is still running on that Android…


Change for a drone flying with Go4 (what I did recently). This “joystick” procedure is a mess.

Here is a very similar thread: Air 2S Gimbal Locked -90 - Waypoints - #5 by Eric_Dominowski

Yeah, I think I seen that. It is over a year old, until the thread starter gives us an update?
Anyways… :ok_hand:


Maybe this Air 2S experience will be helpful: I had a simple mission with 12 waypoints and a single POI that flew perfectly until I added a waypoint and slightly adjusted another one. The gimbal would then point toward the POI but it would not pitch down toward it no matter how many times I double-checked and reset the waypoint gimbal parameters. I then completely deleted the POI and then recreated it exactly the same and everything worked perfectly. One of those go fig’r things I suppose. Good luck.