Air 2S Gimbal Locked -90 - Waypoints

I have tried multiple settings in the Mission Hub. Run the virtual missions in Google Earth and all looks well. Get it up in the air and to 1st Waypoint, start mission and bam, rolls right down to -90 and stays there. Drone stays pointed at POI through all waypoints, but camera locked at -90.

Samsung S22 Ultra. I rolled back my Firmware to a version that supports Drone Hacks NFZ removal and altitude limit removal. Mostly because I don’t want DJI telling me where and when I can take off and fly. I pay attention to what the FAA requirements are. Could this be the problem?

1 Like

Is your gimbal pitch mode for each waypoint set to “focus POI” or something else?

1 Like

Tried FOCUS POI and Interpolate and put in the angles. I will have to try again, but even in Disabled mode, I could not control it manually during waypoint mission. I know that is what some have said they were doing before the DJI firmware supposedly fixed it. I have Drone-Hacks NFZ and Altitude hacks on my aircraft. Requires an older firmware version. I have a ticket into them to see what if anything there is I can do. Don’t want to lose those hacks.

I am having this exact same issue as well with my air 2s and have not been able to resolve. Let me know if you find a solution. It’s odd because when viewing the mission on the mission hub, it shows the correct gimbal angles for each waypoint in reference to pointing at the POI. Never had this issue with Mavic Pro, so I’m hoping an update will correct soon.

2 Likes

Same here. Disappointing. I’ve also had no issues with the Mavic Pro 2 on the same pre-programmed flight