Virtual Litchi Mission (Windows App)

Download lastest version at Virtual Litchi Mission

Video Tutorial

Made by Namirda

3 Likes

Hi. I keep getting API quota exceeded from Google Earth Pro when using this.

it does not open it just make noise

There is a plugin in the chrome store that does exactly the same which doesn’t seem to be affected by the API quota

Plugins can be found here : Litchi Virtual Mission (Browser Extension)

Was working great until Friday the 11th. Now it just sits in the task bar without launching

This is what I’m getting now in the Activity log. I was able to get the window app to operate again by going to where the app was appearing on the task bar but not the desktop. I hovered my mouse just above where the app was showing on the task bar and noticed a small window appear. I right clicked on the window and brought up the option to maximize and low and behold the app appeared. I thought great, but then I got the following message from the activity log:

Google Elevation API returned error
4:44:02 PM OVER_QUERY_LIMIT - You have exceeded your daily request quota for this API. If you did not set a custom daily request quota, verify your project has an active billing account: Google Maps Platform - Location and Mapping Solutions
4:44:02 PM Error Getting WP Ground Elevations from Google Earth
4:44:02 PM Error Correcting Waypoint Altitudes for reference

VLM uses the Google Elevation API to get its elevation information using an API key which is shared between all users. If usage of this key exceeds a certain daily limit then you will need to either wait until the next day when the quota is reset - or else get your own key from Google. You can open an account with Google here. Google will require you to enter your credit card details but unless your usage of VLM exceeds 40,000 hits in a month you should not be charged anything. You can enter your own API key into VLM in the Google Tab of VLM Settings.

Thanks for the explanation. I looked on there website but could not figure out exactly what I was supposed to do. I will give your suggestion another try.

Or if you install the plugin from the chrome store you don’t hit this problem at all

Hello,

The Chrome extension was working a few days ago. Now when I try to export to a VLM I get an error “flylitchi.com says Can’t covert to klm:”. This was a very useful tool. What can i do to get it working again?

Thanks you,
Alan

Not had any problems here with the extension, maybe try clearing the browser cache

Same here, no problem.

It just started. I’ve tried on another system and cleared my browser. I also tried Firefox and I get the same error. My buddy tried one this Mac with this Litchi account, same error. What do you think could be the issue?

I connected my laptop to my hotspot and was able to do the export. My firewall is set up very restrictive. I allowed flylichi.com, but that did not resolve the issue. Do you know what domain is used to do the conversion?

Hello everybody!
There is already a new version
Virtual Litchi Mission V2.6.0

Virtual Litchi Mission V2.8.0 is now available and will hopefully fix the recent problems

Please download it here

3 Likes

Virtual Litchi Mission V2.8.0
I cannot get the new version to open and run, even as
administrator.
Advice please :smiley:

==========
ok I have found the problem =
windows security system was blocking the program
because it came from another computer.
All works good now.

1 Like

Hi Amy,

You deleted your post for some reason - but you are quite right!! There is a problem with the plotting of waypoints generated by the helix/orbit option. I will fix it up shortly.

Just FYI, there is more active discussion about VLM on the MavicPilots site - link is here

Thanks

N

1 Like

Namirda- thank you for looking into this! I had just started digging into the helix function before it went awry and started questioning myself and was going to look at it again today to see if I was missing something. Your help is appreciated.

1 Like