Technical issue with Litchi Pilot app & Mini 3 Pro

hi Im new here so still finding my way.

I am seeking some technical assistance with regards to Mini 3 Pro and Litchi Pilot app.

I have a Mini 3 Pro that I would like to fly waypoint missions with.

I create waypoint missions in the online Litchi Hub and open these missions in Litchi Pilot app on my Samsung Galaxy Tab Active 3 Android 13 tablet.

Before I connect my Mini 3 Pro to the Litchi app, I force stop DJI Fly in Settings on my tablet.

I place my M3P on the ground and switch it on.

I open the Litchi app and once my drone has connected to it and I can see the camera view on the bottom corner of the tablet screen, I press the Folder icon and load a saved mission and this then shows the created waypoint plan on my tablet screen.

I then press the Play symbol to load the mission into my Mini 3 Pro and a Start Flight window opens on my screen showing ‘Starting Waypoint Number’ with “1” presented underneath it.

I press START and then immediately hear a female voice from my tablet saying “Flight ended”.

I have made sure all software (the drone, the tablet and DJI Fly app) is up to date.

I am using the Litchi Pilot app downloaded from this Forum
( [OPEN BETA] Litchi Pilot - Beta Feedback - Litchi Forum (

I am able to launch and land the drone using Litchi Pilot app and I am able to fly it and I have tried the same procedure of loading a mission with the drone hovering in the air. Every time though the app always responds with “Flight ended” in a female voice whenever I press START in the waypoint start window …

… any suggestions to fix this error? Or to explain to me the correct steps if I am doing something wrong.

Any suggestions (but no advice needed thanks regarding system and software updates and DJI force stops) would be gratefully received.

I look forward to responses from the forum.

Does this happen with ALL of the missions that you try to run? or just a particular one?

I have created two missions and both are experiencing the same issue when I try to run them

Sharing one or both of those missions will help diagnose the issue.

One other thing to check is the Maximum Altitude setting in the Litchi Settings (not mission settings)

Max altitude height is set to 120m in the Litchi Pilot settings.

Smart RTH is turned OFF

Enable Augmented Reality is turned OFF

Sync Local Flight Plans is turned OFF

How do I share waypoint missions here on this forum?

1 Like

Mission Hub - Litchi (field)

Mission Hub - Litchi (circular flight around farmhouse)

For me i needed to do all firmware updates etc first with DJI Fly App.

Set it up properly first with DJI tools.

As I said in my original post I had made sure all firmware was up to date. In the end it was a settings issue in DJI Fly causing the problem. I had configured the flight controls to a custom setting as Im left handed … for some reason Litchi Pilot didnt like it. Once I set the controls back to standard settings in DJI Fly, carried out a forced stop of DJI Fly in the tablet system settings and relaunched Litchi Pilot app then it was able to load the waypoint mission into the MP3 and fly successfully.

I had the same issue but my problem was I didn’t scroll down to accept the location permissions when starting the Litchi Pilot app as I didn’t see those options. I clicked out of the dialog thinking all was good. After accepting the permission all was good.

Confirm that your Cine/Normal/Sport setting is Normal. Litchi does not fly in other modes.