Not working on Galaxy A13

hello together

after starting the Lichti app (DJI mini2) starts that DJI database download. Once this is at 100% the app disappears.
Is the app not compatible with Android?
I use Android, Galaxy A13.
How can this problem be solved or do I have to use another app? Would be very very happy to find a solution. Can’t find anything on the internet.

try here, I can’t remember if they came up with an answer

Hello @Nobbi, check out this thread concerning the most recent Litchi update and how it affects certain phones and tablets.

Known Issues in Litchi 4.26.2 on Android:

  • Startup crash on some android devices (Samsung A13, Moto G Pure, etc). This is a bug in the latest DJI SDK version, we will update Litchi as soon as DJI fixes the crash. If your device is affected, please use 4.25.0 in the meantime.
    Known Issues with current release versions
1 Like

Thank you for the quick replies.
I have tried all the suggested solutions but none of them work.
The older update is somehow no longer present.
As I see it, there is no solution available except to use another app.

Yes it is, click on ‘4.25.0’ in the reply from @Steve_Amerson

1 Like

Hello, i am an absolutely newbie on flying drones and think about to buy a Mini2 for startup.
I have a Galaxy A13 4G and i found this conversation here in the forum.
I have tried some other apps on Playstore like UGCS and so on, but no one really work with this phone. For testing i have get the Mini2 from my friend here that i could possible buy in case that he has orderd already the Mini3.
Can anyone help me to find the answer if the App 4.25.0 or 4.26.xx work with my Android phone ?
Is it possible to get a free trail version or do i have to buy it without notice of possile working on the Galaxy A13 4G when i download it from Playstore ?
Thanks a lot for reply.

Update : 4.25.0 works fine with the Galaxy A13 4G.

1 Like

Update again … since i try now to fly the drone several times, the app 4.25.0 always crashes while startup. Sometime i can start the app three time in a row and fly, sometimes it crashed the first time. The only thing that i can do then is to uninstall, start the mobile with rebbot and install 4.25.0 again, configure it new and start to fly…that takes a lot of time instead of flying my mini2.
Can someone send me a link to earlier version then 4.25.0 ?
If i think the mini2 is supportet since version 4.20.x Mayba one version would work since 4.20.x and 4.25.x ?
Thanks a lot.
Best regards

Next and last Update from my Galaxy A13.
Now that nobody seems to be able to send me a link to download earlier version i am realy dissapointed and resigned. The App is still crashing sometimes on my A13.
Now at last i bought a Galaxy S20 because flying with app crash on A13 is now not funny anymore …