Mission stopped - flight mode aborted error while trying follow me

Today I wanted to try another follow me test with the litchi app on my Android phone and DJI Mini 2.
This was not the first test, and eg last week I tried and everything worked fine.
So today I started in fpv mode and flew to 20 meters high. Next I switched in the app to follow me mode, and set the height to 65 meters / 45 meters distance.
I started on my bike and tested the follow me for about 1.5 km. Everything just worked perfectly!
So I brought the drone down and switched to a new loaded battery. Reason I wanted to go back the same route and test everything once more.
So I switched off the drone and the app and the controller. Changed battery, started the drone and started the controller and app again. Within fpv mode I flew already to about 20 meters high. Then I switched to follow me in the app and had the same setup as in the 1st run. However I received the following message on my screen (translated from Dutch): mission aborted - flight mode was changed…
So since the drone was still above me I brought is down and switched it off. I also closed the app and switched off the controller to restart everything again. So after the second and even the 3rd attempt, I continued to receive the same error message “mission aborted - flight mode was changed…”
Note that I double checked that my drone was still in Normal mode since nothing was changed.
So now I dont know what to do next? what went wrong? what has caused this ongoing error even after turning off the drone, controller and app. ? the error kept coming so what is the problem? Can anybody help? as you will understand, I am very nervous know in trying the follow me again…

Some extra input to the issue reported above…Just opened up the Air data app to see if I could discover any issue. Only thing I noticed, that although I switched in the app from fpv to follow me, in the air data app this was not recorded (no switch to joystick mode).
Next I noticed the following notification in the airdata app: “Reached maximum speed of 3.1 m/s”.
I dont understand this, as mentioned above, I launched the drone the second time and wanted to go back the same route…Maybe this extra info from airdata can help in solving this problem…?

You don’t have to take off at 20m to enable follow mode. Can be turned on even when your drone is in your hand. Check the flight mode on the remote

The flight mode was all the time in Normal.
And yes i know there is no need to first go up 20 meters in fpv before switching to follow me.
As a matter of fact, with the above mentioned error, i also tried to start the drone directly from ground via follow me set to 65 meters.
But i received directly the same error message.
So no clue what is happening…
Maybe the staff from Litchi have an answer?

This looks like the maximum Ascent/Descent speed (3m/s in C- and N-mode).

Also check if Payload Mode is disabled.
Mini-2 User Manual page 36:
“After takeoff, Payload Mode is enabled automatically if payload is detected”
Perhaps the drone somehow thought there was a payload.

I did not check if payload was enabled (also did not see this in the airdata). But with the error message, I turned off the drone completely and also shut down the app and shut down the remote controller.
But after restarting everything, the error message came back again…So not sure what was happening.

The error “The flight mode was changed” happens when for at least 3 seconds Litchi detected that the drone is no longer in JOYSTICK mode (shown in middle of top bar). In order to control the drone, it must be in JOYSTICK mode. Most likely Litchi switched it to JOYSTICK mode and the drone switched back to GPS or other, and did not stay in JOYSTICK for some reason.
It could be for example due to a no fly zone (check Geo Zone Map - Fly Safe - DJI), or the mobile device being very laggy, there may be other reasons too

3 Likes

Thanks…i was definitely not in a no fly zone and my mobile device is a Samsung S10.
Until now, i was not facing any other issue when eg flying waypoint missions.
Hope somebody can inform what is happening…

You had to “stop” litchi in your smartphone in the settings.

Thanks but not sure what you mean?
Since i turned the drone and controller and app fully down (so closing them and turn power off), and received same error message after turning everything back on again, i dont understand what was happening…

Just got a similar problem. Completed 2 missions, then pressed rth and canceled it when the drone was over me. Turned on the orbit, and received the same message. Landed, turned off, turned on, the drone began to orbit.

Im having the same issue, but in a no fly zone. Any ideas?

It would help if you provided more details.

If you are in an “Authorization Zone”, you will need to unlock that zone either with the DJI app or on-line using DJI’s “self-unlock” web site then transfer the unlocking code into your drone using the DJI app.

Once the above is completed, you should be able to fly using Litchi.

This is my first time using litchi, really trying to get use of the waypoint flight feature to so progress flights of our jobsites. I’m using a DJI Mini 2. Anyhow, I attempted my first waypoint flight over a jobsite near an airport. When I started up my drone in the Dji Fly App, I unlocked the zone restriction so I could fly. Then I jumped over to the Litchi app and got my bird up In The air. From there I pressed play on my flight with only 2 points. Once it reached the first point to begin the flyover, an alert popped up that said Mission canceled because the flight mode was changed, or something like that. I tried the same thing with an orbit flight and had the same problem.

Did you ever get a solution to this? Seems if DJI Fly can fly in Geo Zones with Authorization Litchi should to? Having same issue with Mini 3 pro and New Litchi Pilot App

You have to STOP the DJI Fly app before starting a Litchi mission. You cant just switch from the Fly app to Litchi. Litchi missions will not start if DJI Fly is still running in the background.

I’m kind of forced to go into DJI Fly first to make sure the GEO Unblock is active (when I’m in a GEO zone i.e. where I live) but I always turn it off before I launch Litchi Pilot. Do you mean to Force Stop DJI Fly in the Apps section of settings?

Yes exactly that, Andrew

1 Like

Thank you all

Will give this a whirl tomorrow and report back.

2 Likes

CAUSE OF “FLIGHT INTERRUPTED. FLIGHT MODE CHANGED” AND MISSION NOT RUNNING
So I trialed my mission outside the Geo Zone and it ran fine! So the Geo Zone appears to be causing the issue. I’m hoping Litchi can sort as even though when in a Geo Zone the mission won’t run you can still fly the drone manually using the Litchi Pilot (after you have gotten authority from DJI) so if you can fly it manually there must be something triggering the flight mode change in the mission scenario that Litchi can fix. Here’s hoping… I have also passed feedback via the app option.

I’m pretty sure when I had the Mini 1 I could use missions in my Geo Zone using Litchi so hopefully is just a bug that can be solved.

The Force Stop on the DJI Fly app made no difference unfortunately.