How do I get smooth tracking in waypoint mode?

When I fly a waypoint mission the resulting footage looks like I’m sitting in a jerky robot rollercoaster, not the smooth turns I can do by hand.

Any tips ?

1 Like

The jerkyness that you describe is most likely due to the mission being flown using a DJI Fly drone.

In DJI Fly drones, DJI has removed the ability to upload the entire mission to the drone and have the drone autonomously fly the mission. Instead, Litchi is forced to use the inferior “Virtual Sticks” method to execute waypoint missions on DJI Fly drones. Drones with onboard waypoint capability are able to perform yaw transitions much more smoothly than DJI Fly drones using the “Virtual Sticks” method.

I have heard of some having limited success in smoothing out the yaw jerkyness by making some gimbal adjustments in DJI Fly. In DJI Fly, access the main menu and select “Control” then “Advanced Gimbal Settings”. Under “Normal Mode”, change the Yaw Speed from the default of 75 to something smaller like 35. Also change the default Yaw Smoothness from the default 7 to something like 70. These changes are saved to the drone and will affect flights with Litchi as well. I have tested this and I think I see an improvement in waypoint missions but I’m not 100% convinced.

5 Likes

hello, could you share a small piece of your video? I want to understand if this problem of yours is similar to mine. Maybe you even say with which drone.
Giuseppe

Capripiu, It is a Mini 2. I will fly a mission with Mini2, then a phantom, then manually and post some video

Hello everyone.
I purchased LITCHI for my iPhone just a couple of days ago.
I tested it for hours (yes, got several batteries for my DJI Mini 2), read tons of tutorials, watched dozens of video and hints aroud the web, modified parameters in DJI Fly App trying to find a smoother way to use it with waypoint but no, no way.
I needed it for a project I have in mind but seems like there’s no solution to that.
Even setting a mission with only 2 point, with a simple movement from A (25 meters high) to B (1 meter high), with no POI and setting the the gimball to “manual” gave me a movement as smooth as having Parkinson desease (no offense).
If I can’t find a solution I think I will ask for a refund.
Best

Without the use of poi, there will be no smooth movements.

Thx for your reply.
I tried without POI because I had no good results setting one or more.
Setting just a straight line I expected there would have been no “shacking” due to the software trying to point a… point (also because for my project I need to be in control of the gimball).
I was wrong.

As I understood from your message “heading mode” you put in “user controlled”. In no other mode except WD, the litchi will give smooth turns and bumps.

“WD” stands for?
'cause I set the front of the drone with a fixed value in both waypoints.
It should go straight without moving but it doesn’t…

1 Like

This is incorrect. Using a POI to specify a heading or directly specifying a heading value are two different ways of accomplishing the same thing – defining a heading at a waypoint. The drone linearly interpolates the heading between waypoints in either case.

1 Like

WD stands for Waypoint Defined.

1 Like

Let’s discuss the settings you have set for clarity.

1 Like

I don’t understand why you say it’s incorrect: if I set a precise heading value, the drone should go “straight”, shouldn’t it?

Because if you have gimbal lock set, the video will look like you don’t have a 3-axis gimbal on your drone

The most easiest way… (Guess if you know the app the language won’t be a problem)

Sorry but I could’t upload 3 pics at once :wink:

Both waypoints have the same values, except for the altitute.
“Gimball lock”? It’s not “locked”: it’s simply disabled to let me handle it manually.
And the problem is that the drone turned his head not respecting the heading values.

P.S. What app is that??? Is it for Android? The GUI is completely different…

1 Like

I’ll try to send you my settings.

1 Like

No not like this. The drone with its camera looks in the same direction as in wp1. But the height of the drone changes, which means that the drone’s camera should tilt.

Show all the settings, this is not enough

1 Like

I am using android

1 Like