How do I get smooth tracking in waypoint mode?

I just bought Litchi too, to my dismay it is not useful.
Maps are inaccurate for me to rely on it for any mission or even implement a simple waypoint plan. The claim is that it’s because am in China… which is a lame excuse.
Apple Maps is available in Litchi, and I use Apply Maps for my commute around on my phone… it’s dead accurate. I don’t use Google Maps because its not available, and the alternate Drone Apps out there, including Drone Harmony, Map Pilot Pro are all working fine in China.
I’ve not asked for refund in hope that I can be a support for them to improve the App someday – fingers crossed. Simply stated, am investing into the future, but currently it’s not providing any valuable function to my drone flights.

1 Like

Have you tried these two options?

  • Use Amap Imagery (for China Mainland): To be used in conjunction with the “Calibrate Map for China Mainland” setting. When the map is calibrated, Google’s imagery will not map to their true location, enable this setting to fix it. iOS only.
  • Calibrate Map for China Mainland: If you are in mainland China, enable this setting to get correct GPS coordinates on the map. iOS only.

There is no option to switch to Amap Imagery in my version and where do I calibrate Map?

They are general settings, but only available with Google Maps, not with Apple Maps.


@TriBar thanks, that eventually worked. So i can try a few missions to see level of accuracy, but at least my location is located ~correctly on the map.