Gimbal pitch problem during waypoint mission

Mission: Circle above building site
POV: one in center
drone: DJI AIR2 S
mobile: Android

Waypoints: 31WP used taking the drone twice around the center (- 5m elevation under the ground floor)

  • Instructions: WP1: Turn on video, go to WP2, etc
    Camera was instructed to watch POV 1 as it circled. The gimbal pich is setted in “focus POI”.
    The POI 1 altitude is 0.

Just the mission started the camera tilt down to the ground and during the whole mission the angle of the camera remains knocked to the ground. I tried to change the POV altitude to 3 m, but nothing changes. What I’m doing wrong?

1 Like

Can’t access the mission from the link you posted ( Mission Hub - Litchi )

ops, how could I share a mission :frowning:

The link you posted may be correct. The step you need to do is to go into the “Open” dialog in the Mission Hub and uncheck the “Private” checkbox. After doing that, we should be able to see your mission.


You are the second person who posted about this problem (camera pointing down) recently. I looked at the other person’s mission and there was nothing in the mission that would cause that to happen. I then transferred their mission to my location and flew it. Their mission was executed properly using an Air 2s. I suspect that once your mission is shared, there would be nothing in it that should cause this problem either.

Once we see your mission, we might have suggestions but one thing I noticed from your screenshot is that some of the waypoints appear to have a curve size of zero. Is that really what you want? I would suggest that you check each waypoint and set the “Curve size” to a non-zero value. That should at least produce better video results.

Also, would you tell us if your other missions behaved properly? Is it just this particular one where the camera points down or is this your very first mission?

1 Like

Yes, I’ve read on the forum about a similar problem.

Now the sharing could work. First of all I’ll change the curve value, but I’m afraid isn’t the problem now.
All the mission works properly, except the inclination of the gimbal for the whole mission.
In real it’s the first mission such complicated, but I’ve already use the waypoint with gimbal pich focused on a POI and It worked.

I wonder if toggling ‘above ground’ on everything will ensure the gimbal angle calculations are based on relative elevations rather than potentially calculating based on the barometric elevation reading? That may be a potential issue for some models? Or at least ‘above ground’ on the POI

1 Like

I can now see your mission.

As I suspected, there is nothing in your mission that should cause the gimbal pitch angle to be -90 degrees (pointing down). All of your waypoints have the gimbal pitch set to “Focus POI” and I can see the calculated gimbal pitch angles. This mission should work.

When flying this mission, are you located near this location or are you flying from some distance away? I want to rule out a signal loss issue.

I have flown hundreds of missions and I have never experienced this problem. I’m going to suggest a few things. None of the things I suggest will have anything directly to do with your gimbal pitch problem so you wouldn’t think they should make any difference. These suggestions will only make your mission more similar to the ones that I fly.

  1. Make sure that none of the interior waypoints have a curve size of zero. If you are capturing video, you don’t want a curve size of zero. Smooth turns will look much better.
  2. In “Settings”, the preferred “Finish action” is “RTH”. While the others may be valid under certain conditions, RTH is usually the safest to use. You have it set to “Hover”. If you leave it set to “Hover”, and then forget about it, then design a mission where your last waypoint is far away, you may wonder why your drone done does not come back to you.
  3. If, at this point, you still see the gimbal pitch problem (and there’s no reason you shouldn’t), try setting the “Gimbal pitch” mode to “Interpolate” for all waypoints. The displayed angle has already been computed as shown in Mission Hub. The “Interpolate” setting will use the displayed angle and you should see proper results.

I wish I had something more definitive to say, but since there is nothing configured in your mission that should cause this behavior, you will need to try some troubleshooting steps like this to see if you can find anything to correct this behavior.

Please keep us informed and let us know what device are you using to fly it with.


Did you check the firmwares of both your drone and your controller?

1 Like

I like using “Interpolate” because it is predictable and smooth. The only trick is getting a feel for the perspective of the different angles so that it is intuitive and comes naturally. I watched my camera twitch while focusing on a POI so “Interpolate” eliminated this particular issue.

I can I do it? In my waypoints the curve size cursor is fixed at 0 and unshakable!

You should be able to either:

  1. Use your mouse to move the slider
  2. Enter a new value into the text field

I can change your “Curve size” value for waypoint 5 in the mission that you shared.

It is not clear to me why you cannot.

Stefano’s original problem: Gimbal Pitch to -90°, used to be a known issue with the Air2s, but was resolved with the firmware update from 3/15/2022:
New Air 2S firmware Released (3/15/2022)
Date: 2022.03.15
Aircraft Firmware: v02.04.21.50
Remote Controller:v04.12.00.56

In his post #6 he wrote he read a thread of a similar problem.
In post #10 of that thread I wrote the above cause and solution.
So in post #8 I asked him if he checked the firmwares of his AC & RC, but he never gave an answer.
And now the speculation has begun…

1 Like

Yes. It would be beneficial to all if Stefano would act on your recommendation and then get back to us with the results. This would go a long way for others who have reported the same problem.

Thanks for pointing out this solution.

1 Like

in my missions I can’t change the curve value in any way.

could you? it’s freezed

I can change the curve sizes of WP2, WP3 & WP4.

What are the firmwares of your AC & RC ?

I took your mission, changed the curve size to 100 for waypoints 2, 3, and 4 and shared it:

1 Like

I update it now. I’m going to try it. Finger cross

Check in settings, see if ‘curved turns’ is turned on.
If not, curve size will be locked on zero.
Beware, when the drone does curved turns, there are some actions it can’t perform at waypoints (since it doesn’t actually stop at them). These actions include starting/stopping video and taking photos. I’m pretty sure gimble angle changes work though.

1 Like

Hello. I create a test mission easier then the original one with 2 circles (the one that didn’t work)
Before taking off I did:

  • update DJI AIR 2s firmware (aircraft and controller)
  • reinstalled the app litchi on my mobile
  • curved all the waypoints
  • set RTH as finish action

Setted like this the mission works quite well. The gimbal points the POI quit well. It’s not always perfect in the frame, but it’s a big improving then the tilt down (-90°) of the previous one.

The challenge is now retray the original one. I’m trying it the next week. I’ll keep you up
Thanks a lot for the support to everyone.