Air2s Camera 90deg down during WP Missions

Could someone take a look at my WP mission configuration,
and help me to understand why the Air2s camera points straight
down when using POI during this WP mission ?

Mission Hub - Litchi

DJI Air2s
Samsung S9+
Android Version 10
Litchi App version v4.24.1-g
Aircraft Firmware 02.04.2190
RC Firmware 04.12.0046

TIA

Looks ok flying it in Google earth

Here is a YT video of the screen recording of the mission.
I cancelled the WP mission after Air2s reaches WP#2

It’s clear to me that the problem is in the information you entered in your mission. Camera behavior is normal when the drone is heading to the first waypoint. However, upon reaching it, the drone makes a hovering flight (which this information is certainly included in the mission of that waypoint) and turns its camera down and keeping heading to POI 3 (which I believe is also part of the setup of the mission that was created) until the drone reaches the second waypoint. After that, you can see that the drone keeps heading to POI 3 and continues with the camera down. Only after the mission is canceled and the FPV function is chosen, the camera returns to the horizon line. Send some screenshots of the mission setup. Maybe we can identify something. Hugs.

Hello Robson,

You should be able to access the mission here. I turned off the private setting and enabled sharing for this mission :

Thank you for taking a look.

Hi Brian,

What you have shown is really strange. I have flown countless Litchi missions (and some with an Air 2s) and it doesn’t behave as shown in your example.

While I don’t see anything obviously wrong with your mission, there are a few differences between your mission and ones I typically fly.

  1. When capturing video, people typically used curved turns. You are using straight lines. Just for fun, try switching to curved turns and apply an appropriate curve size at each waypoint.

  2. Your “Default Gimbal Pitch Mode” is set to “Disabled”. That shouldn’t cause a problem as your waypoints are set up correctly. Just try changing your default to “Focus POI”.

I don’t know if these changes will “fix” your mission. However, they will make it more like ones I usually fly.

Also, I noticed you switched to FPV mode when flying home. There is no need to do that. You can cancel your mission and just fly normally. There is no need to switch modes.

I also noticed that the gimbal pitch angle shown as your mission is being flown stays at “zero”. This is due to a bug in DJI’s current SDK and shouldn’t affect your mission.

Let us know if you have any success.

Thank you for the suggestions. i should be able to re-fly this mission tomorrow and reply
to this thread with the results.

One other thing that I have done is uninstalled and re-installed the Litchi app
on my Android phone.

Thanks again.

I saw your mission. Well, I’ve never setup like you when it comes to Gimble. For each waypoint the Gimble has a configuration. Now Focus on POI and on other Disabled and also Interpolated. I can’t guarantee it, but it might solve the camera problem if you choose only one type of Gimble Pitch. If that works, try out small changes one by one. It might solve it. Try it and then let us know the result. Good luck and good flights.

This used to be a known issue with the Air2s, but was resolved with the firmware update from 3/15/2022:

New Air 2S firmware Released (3/15/2022)
Overview:
Date: 2022.03.15
Aircraft Firmware: v02.04.21.50
Remote Controller:v04.12.00.56
DJI Fly App iOS: v1.5.10
DJI Fly App Android: v1.5.10

Your RC firmware (04.12.0046) is not up to date.

1 Like

Good catch.
Not sure how I missed this, but RC Firmware is now upgraded to 04.12.0056

Good morning Brian, I don’t know if you performed your new flight but I saw that you changed the settings of your mission about gimble pitch mode. I hope it worked. Searching the internet I found a very interesting article about Interpolate. Read on this link - Learn about the Litchi Mission Hub - Drone Photography Services - specically the part about Gimbal Pitch Mode. Let me know the results.

1 Like

From the mentioned article:

“It allows you to define the pitch angle and the heading of the camera at each waypoint”

This is a FALSE statement.

It ONLY allows you to define the pitch angle of the camera, NOT the heading !

From Litchi’s Online User Guide:

“For “Interpolate” to work, the previous or next waypoint need to be set to “Interpolate” as well. Litchi will then automatically adjust the gimbal pitch angle to start and end at the specified angles, and smoothly transition while travelling between the two waypoints.”

Update : I flew 3 new WP missions today. No issues, which is great :smiley:

Just a guess, but more than likely updating to the latest RC firmware
probably fixed my 90 degree camera issue and/or maybe reinstalling the Litchi app helped too.

I tried each of the suggestions that wesbarris suggested above
Curved turns and straight lines with photos, stop and starting recording, 5 second pauses.
No issues with either now.
Also setting the Default Gimbal Pitch Mode to ‘Disabled’ and ‘Focus POI’ .
As long as each WP was configured for Focus POI, I don’t believe the Default Gimbal Pitch mode effected the Gimbal / camera position during these 3 missions.

All 3 missions were successful.
Camera stayed focused on the POI.
Action lists were completed successfully(if configured).

Note : I did have to turn off Collision Avoidance(APAS) off before I was able to start the mission.
Error : ‘Flight Mode changed’ when I would try to start the mission with
Collision Avoidance set to ‘Bypass’.
And I was able to turn Collision Avoidance (APAS) off in the Litchi App,
and that allowed the WP mission to go into ‘Joystick’ mode and execute the mission
There was also a small bit of tilted horizon in the photos and video. But I did neglect to
do a gimbal calibration after the firmware update.

Robson/Tribar : thank you for the info on Gimbal Pitch Mode.

Very much appreciate everyone’s suggestions and help.
Thank you

1 Like

Hi Brian, good morning. I’m glad you found the solution. Unfortunately there was no certainty that it was the update that solved that little problem. Can you on a next mission try that old setup on the gimble pitch? It’s just an attempt to have conviction of what really solved the problem. Was it the new setup in the gimble pitch or the firmware update? Hugs.

Re-flew the shared mission.
I think this YT video proves the point that setting Default Gimbal Pitch mode
to Disabled or FocusPOI did not resolve my initial problem with the camera pointing directly down vs at the POI.
At the ~5:45 mark in the video I change Default Gimbal Pitch mode to FocusPOI and increased the flight speed. Both of these flights look identical regardless of the Default Gimbal Pitch mode setting.

IMHO - My issue was resolved due to the firmware upgrade and/or reinstalling the Litchi app.

Thanks again.

il POI è settato a metri 1 devi aumentare il metraggio se imposti 20 metri vedrai che la fotocamera non punta in basso avendo impostato l’altitudine del drone a 45,7 è normale che punti in basso.