Gimbal pitch problem during waypoint mission

Thanks for the update, Stefano. I’m glad it worked. My guess would be that the firmware update (as @TriBar suggested) fixed the problem. Let us know if the larger, original mission also works now.

I have a New DJI Air2s and had the same problem. Found out that my WIFI would not connect to DJI for an update. It never said that it did not update when I tried it. Found that I could use my Phone WIFI and updated the Firmware, Works great not. Software MUST BE UP TO DATE

1 Like

I was also supposed to write about the problem with the gimbal during the mission, but I can already see this discussion thread.
Mavic 2 Zoom drone, the latest fimwrare. I have already completed many missions. I set each WP separately manually, also the angle of inclination of the gimbal, each point has a soft curve, I also manually set the direction of the drone. Often the gimbal stays in the position from previous WPs and does not execute subsequent commands. I often have poor RC coverage then, or am completely disconnected. Shouldn’t a mission be fully loaded with all instructions before executing it?

I have had a big problem with this recently because I usually perform BVLOS missions at rather low altitudes. I also have the impression that I have not had these problems on older software before.

Regards Roger

When using a Mavic 2 Zoom and the IOS version of Litchi, the waypoint mission is completely uploaded to the drone except for the following:

  1. Gimbal pitch angles at each waypoint
  2. Custom speeds at each waypoint

If your drone flies out of controller signal range during a mission, the above two parameters will NOT be executed.

You did not mention whether you are using the Android or IOS version of Litchi. From your description, I would assume you are using the IOS version.


At the moment I have purchased and use the android version of Litchi. And so I wonder if the iOS version will bring me any additional benefits. I had to buy an apple tablet (although I hate this company) specifically for the Inspire, as there are a lot of problems on android with DJI GO and the flight range of the drone.

So I had a good suspicion that problems with setting the gimbal angle are always when I’m offline. So there is no cure for it?

BTW, I regret that the new DJI drones do not work on litchi, now I do not see any point in buying a Mavic 3 or Mini 3 Pro. How does your cooperation with Autel drones look like? I am already very fed up with DJI and their policies. Inspire 1.2 and Mavic 2 are my last drones from them.

Litchi’s “What’s New” page says this:

Android: Litchi for DJI Drones

Version 4.25.0 (July 4, 2022)

  • [DJI GO/older drone models only] added new setting ‘Enable DJI’s Gimbal Interpolation in Waypoint mode’ to allow gimbal pitch movements out of signal range

So, if you are using the Android version, there should be a setting that allows you to enable gimbal interpolation when out of signal range. I would check that.

There are some slight differences between the Android and IOS versions. The one mentioned above is a benefit of using the Android version.

I agree. Because of this, I currently have no interest in either the Mavic 3 or the Mini 3 Pro.

This is fantastic news, it is worth reading carefully the changes after the update sometimes. Lovely my movies will be perfect now. Thanks a lot for this tip!

I see that I have to buy another Mavic 2 drone as a spare because the new DJI products are useless to me. And of course ridiculously expensive.

1 Like

I see way point actions can’t be done when you set the path mode is curved turns. It is clearly shown in Manual.

Welcome to the Litchi forum.

That is correct. However, it doesn’t have anything to do with the gimbal pitch changes mentioned above.