Waypoint Mission Flys at Angle

I’m using the latest version of Litchi for iOS on an iPad 4 flying a Phantom 4 Pro V2. When I run a Waypoint mission, it follows the correct path but the drone flys at a slight angle so as the drone heads straight forward, it records approx 10 - 20 degrees to the left of the actual heading that was saved in the mission.

Has anyone experienced this or have any suggestions to troubleshoot. Thank you.

This indicates a lack of precision. Try to fly near the ground and you will see that wp… never matches what is displayed on the map

In general, the drone’s heading does not point along its flight path unless you configure it to do so by either setting the “Heading Mode” to “Auto (TNW)” or by setting the drone’s heading to be tangent to its path. You would have to make your mission public and share the link here for us to see how you have it configured. Otherwise, you will just receive guesses.

Also, when flying manually, and simply moving your left stick forward, does your drone fly in the same direction as the camera is pointing?

My mission is set to Custom for the heading and I set the direction and the camera to where I want at each waypoint.

When flying manual and point the stick forward, everything works as expected.

I will make the mission public and let you know when that’s done.

Thank you.

I’ve made the mission public. Here’s the link; Mission Hub - Litchi

I’m flying between 15 ft and 100 ft AGL on multiple missions in different locations. I’ve used different controllers to see if that’s the issue.


As an example:
In your mission, when ‘Rotation Direction’ in ‘Mission Settings’ is set to ‘Managed’ (default), the drone/camera will gradually rotate from heading 1° to heading 240° Anti-Clockwise between WP8 & WP9.
That’s a rotation of 121° over a distance of 30ft within 10 seconds.

Read/Study the Online User Guide:

Yes, that is my intention. My issue is that the drone/camara does not follow the path that I set when setting the mission. When I run the mission, the drone/camara are off to the left while following the path I set.

And there is. wp has an error of about 5-10 meters. Read my first post again.

The camera is not supposed to follow the path. Instead, it should orient itself to the chosen heading at each waypoint and interpolate between the two headings while flying between those two waypoints. Path and heading are two different things. Perhaps you should experiment with the " Auto/TNW (To next waypoint)" heading mode.

Your mission is curious. At the beginning you appear to have some unnecessary waypoints (2,3,4,5). There is a lot of jerky camera motion during this mission.

1 Like

It seems the user is talking about a common problem with accuracy. For example, if I am near a road, I place points along the road, but the drone will fly sideways for 5-10 meters, as if the map is not configured correctly.

Thank you everyone for the responses. I may be explaining myself incorrectly and I hope this scenario will help explain my problem.

If I setup a waypoint mission that only has two points, and I set a waypoint at the first point, fly directly to the second point and set the waypoint 2 there and save the mission. Then when I execute that waypoint mission, the drone flies fr point A to point B but it will fly in an angle about 10 - 20 degrees. So the result is when recording, I am not getting the footage I setup but rather footage of the drone recording at an angle.

I understand in my example I don’t need to use interpolate but I’m trying to explain my problem.

I hope this helps.

Also on the comment about jerky footage on the initial waypoints, yes I was using this as a test so wasn’t paying too much attention to the first few waypoints.

Thank you again.

Place the poi and point the camera at them. It will get you out of trouble

I’m sorry but I don’t understand what you mean by setting a waypoint at a waypoint. Are you confusing POIs with waypoints? Your description does not address the drone’s heading which you say is the problem.

Thanks. I’ll give that a try.

Hi there. I’m not confusing waypoints with POI. Sorry if my explanation is not clear. Set a waypoint a position 1. Fly straight to position 2 and set waypoint. Now I have 2 waypoints that I’ve created where the drone is pointing straight from position 1 to position 2. When executing the mission, the drone flies from position 1 to position 2 but it will fly at an angle. I hope this helps.

For this to work, you need to set the camera direction to “to the next waypoint”. And you write that you installed “under user control”

I’m sorry, I’m not sure I understand. I’ve uploaded an example of the issue I’m having to the link below. This is the result, I don’t believe I have the mission saved anymore to share with you. But on this example, I was pointing my drone right at the goal posts evenly … straight on. As you can see from the video, the result of the mission is that the drone is flying and recording at an angle. Here is the link Litchi Mission Issue - YouTube

Thank you.

You have it and flies to the left corner of the gate, not only the camera

If you want the camera to point in the same direction as the flite path, you have to set ‘Heading Mode’ in ‘Mission Settings’ to ‘Auto(TNW)’.

All of your posts suggest that you believe the drone should point to waypoint 2 when flying from waypoint 1 to waypoint 2. That is not the case (unless you are using the “Auto (TNW)” heading mode. In “Custom (WD)” mode, the direction your drone points is determined by the heading at each waypoint, not the waypoint’s position.

Back in post #3 I asked you this question:

Also, when flying manually, and simply moving your left stick forward, does your drone fly in the same direction as the camera is pointing?

I have not seen an answer to that question yet.

If your answer to that question is “no”, then what you are experiencing might be a known problem with some of the Phantoms where the yaw seems to be off by a few degrees. If this is the case, I would try these three things (although I doubt they will solve the yaw problem):

  1. Do an IMU calibration
  2. Do a stick calibration
  3. Do a compass calibration

I’m only suggesting those because they are easy to perform and performing them would make sure everything is calibrated properly.

I have read one report of someone solving the Phantom yaw problem by demagnetizing his drone using CFixer. Is it possible that your drone has spent some time near a strong magnet?