Waypoint "invalid 3d distance" problem. Litchi newbie, experienced Mini 2 flyer - SOLVED!

Thanks for any help.

The message I’m getting when I try to run a waypoint file is “invalid 3d distance between waypoint 1 and 2 valid range is (0.6,1999)m”

I’ve tried various flight plans and locations but I’m stumped on this :frowning:

So the 3d distance between your WP1 and WP2 is either:
-less than 0.6 meter
-more than 1999 meter

Search this forum for “DJI SDK Limits”


Thanks for the pointer. I’ve read this post DJI SDK Limits (to keep in mind while planing a mission) and my waypoints should be well between 0.6m - 1999m.

Could you spare me a minute for an explanation in layman’s terms?

I don’t know what that means

1 Like

Ok, I googled it.

You have to use the Pythagorean theorem to determin the 3d distance between two waypoints.
1 side of the triangle is the horizontal distance (h) and 1 side the vertical distance (v).
The 3d distance will be the square root of (h2+v2).


Ok, I just used a Pythagorean theorem calculator and got just over 78m as the result (height increase 10m and 78.1m horizontal distance). Using and online 3D calc, I get a similar figure.

I figured from the original error message that the distance would have to be extremely small or extremely big to fall foul of the tolerances.

My flight plan is five waypoints in a rhomboid shape roughly the size of four football fields, alternating in height: 30m, 40m, 50m, 40m, 30m.

This mission should run, except for the action ‘Start Recording’ at waypoint 1 which will be ignored because it’s a mission with curved turns.
Also the distances diplayed in the mission hub are 3d allready, so no need for manual calculations.

I don’t know why you get the error message unless you changed something that maybe you are not aware of.

I would unintall then reinstal the Litchi app and try again.


I think I know no.
Perhaps the reason is because there is no home point yet, or the home point is more than 1999 meters away from waypoint 1.

1 Like

How do I set a home point in the mission hub? Does that become waypoint 1? (sorry for so many questions!)

You can’t, the home point is set by the drone.
It does not become waypoint 1, that would make no sense since you define all waypoints.

I just tried to fly a mission 3 km away, but Litchi displayes a message that the drone is too far away from waypoint 1 and won’t start.


I’ll reinstall Litchi and try again on Monday, weather permitting. I can’t do it sooner as I live near an airport.

Thanks for your help - I really appreciate it :slight_smile:

I hope it works out for you.
Good night.

1 Like

I managed to get it to work today! Embarrassingly, I was getting the error message as I was not logged in :face_with_hand_over_mouth: Litchi could make that a bit more obvious in my opinion but hey-ho.

My first waypoint flight went perfect and now I’m super excited :star_struck:

You are +1 hour from GMT so I’m guessing you’re not in the UK? If you are, or visiting anytime soon, let me know and I’ll gift you a couple of free coffees. I won’t need your details, I’ll just upload a couple of complimentary vouchers for you. Thanks again for your help :+1:

1 Like

That’s all right, but I really appreciate the gesture.
Thank you.


I ran into the same error message while trying to get 3 images from the same 3D location for a vertical panorama (i.e. for 3 waypoints, I wanted to hover with the same bearing, but change the gimbal angle for each one),. That set up a distance of 0m between the 3 waypoints, so the error displayed when I went to fly the mission. It would have been nice to have Litchi Mission Hub detect the error before trying to fly the mission: the red warning is hard to read, and takes a lot of fussing to fix the issue on a phone screen.

Changing the latitude by 1m between waypoints fixed it, but I ended up just using the Panorama mode to get the effect I wanted.