Virtual mission in google Earth wrong orientation

Where’s the suspension in that?

If wp1 set the angle. He will be like this for the entire mission.

I’m gonna suspend myself from this topic.

1 Like

This is working correctly.
It is not a problem.

When starting at waypoint 1, the drone is heading towards waypoint 2.
BUT … when the drone reaches waypoint 2, at that point, it must be turned to be looking at waypoint 3.

So the drone needs to rotate to the right, all along the length of the line from waypoint 1 to waypoint 2,
so that the drone is looking directly at waypoint 3 when the drone reaches waypoint 2.

Let me remind you about the initial topic.
Why does the camera orientation differ between VLM run in Google earth and the same mission run live with the drone?

Please compare the two recordings and the mission setting!!!

  • In the flight with the drone - the camera turns at the waypoints, not before.
  • In the VLM Google flight the camera starts to turn toward next waypoint long before arriving at the waypoint.

This was confirmed by TriBar above
.
In order to progress the issue further I have brought it up in Mavicpilots forum where the developer of VLM take part.

Ah yes now I understand what you are talking about ! ha ha ! :smiley:

I think that you have discovered something no one has noticed before.
I will make a short mission to try this, but it is heavy rain here for now.

You write correctly. But the author of the topic does not work that way.

Urkman has discovered an interesting anomaly in Virtual litchi mission.

In virtual litchi mission it seems almost impossible to make the
camera keep looking straight ahead right up to the next waypoint.

Even when using point of interest markers to hold the camera straight.

Here I have made a small mission to test this.

Waypoints 1 and 2 are locked to poi 1
Waypoints 3 and 4 are locked to poi 2
Waypoints 5 and 6 are locked to poi 3
Waypoints 7 and 8 are locked to poi 4

Settings = straight lines, no arcs.

Whatever heading settings I use in settings, the camera drifts off
course from looking at the poi marker that it should be looking at.

Eg. At waypoint 2 the camera should be looking directly at poi 1, but it is not.

This may not actually happen in real life.
When it stops raining I will try the drone with this mission.

I don’t consider this as any fault with Virtual litchi mission,
just never experienced this in any of my missions or videos.

Maybe some one who lives somewhere warm and sunny can make a
similar mission and try it with their drone.

I have made a short video to illustrate.

.

Show your mission settings.

Do you have rotation enabled?

No, all headings directly to point of interests.

Heading mode change 1

And default gimbal pitch mode

I now have a received a reply from namirda the author of VLM in MavicPilots.
Quote:
"This issue has come up a few times already if you read back in this long thread (e.g. post 922 and subsequent discussion).

The problem is that Google Earth insists on smoothing out everything and does not properly honour missions with abrupt heading changes like yours.

I think the best you can do is to add a few additional WPs to constrain Google as far as possible. In particular you should add a waypoint just before your WP2 with the same heading as WP1 and another WP just before your WP3 with the same heading as WP2. Note that you will have to set heading mode to WD for this.

I will look into fixing this up in the next release of VLM

N "

4 Likes

Gimbal pitch is completely irrelevent to any of this, it is a separate function that does
not affect steering directions.

1 Like

I told you about rotation direction

You don’t see this option in your settings.

Drone rotates to look at the next waypoint.
In this case points of interest are used as waypoints.