Virtual mission in google Earth wrong orientation

In waypoint missions with setting Heading mode TNW the virtual mission in google earth does not point to next waypoint but seems to look further ahead.
I want to heading to be strict to next wayoint.
Is this a general problem or what am i doing wrong?

In waypoint missions with curved turns:
-The aircraft wil not stop at waypoints because it will never reach them.
-If two adjacent waypoints have different altitudes/headings/gimbal pitch, then these will gradually change as the aircraft flies between those waypoints.

In waypoint missions with straight lines:
-The aircraft wil stop at each waypoint and yaws to the directions of the next waypoint before continuing its flight.
-If two adjacent waypoints have different altitudes/gimbal pitch, then these will gradually change as the aircraft flies between those waypoints.

Agree - BUT this is not the case running a Virtual Mission in Google Earth Pro for me.
Does it work correctly for you?

This is an example with straight lines and no curves - the drone turns before next waypoint - it is supposed to straight to next wp and then turn.

Appended: mission hub settings and a recording from Google Earth Pro


YouTube video:
https://youtu.be/OCXEMIySt7g

Interpolate disable. It’s written about this in the manual.

It should be clarified that “interpolate” affects the rotation and the suspension angle at the same time, and if this is disabled, then there is no way to set the suspension angle. Only if you put poi. Perhaps this function would be good to share. But I like the way it’s done now.

suspension
/səˈspɛnʃ(ə)n/
noun
1.
the action of suspending someone or something or the condition of being suspended.
“the suspension of military action”
2.
the system of springs and shock absorbers by which a vehicle is supported on its wheels.
“modifications have been made to the car’s rear suspension”

1 Like

Same as Virtual Litchi test - in real life.
Same settings gimpal interpolate active.
Evverything works as intended.

The issue is that virtual mission in Google Earth Pro is not working peoperly - compare the flights in Google Earth and in real life.
The question is how this can be fixed.
PS disabling interpotate does not change anything.
Looked at the manual and can not find where it is stated that interpolate gimpal pitch will affect heading.

Here is the video in real life:
Same as Virtual Litchi test - in real life.
Same settings gimbal interpolate active.

And how then to make a smooth transition from one point to another. If you have interpolate enabled in real life, directs the camera from one waypoint to another waypoint.

Interpolate is enabled above -30 deg as can be seen from the video.
I am not looking for a smooth turn in this case.
In order for at smooth turn I would use the curve function.

Have you compared virtual flight in Google Earth and in real life yourself?

My conclusion is that Virtual mission flight in Google earth is not working properly in this respect.

You are not looking, but I need it.

Flying in an arc is just a drone flight. And the smooth direction of the camera is interpolate. I don’t understand why it works like this for you.

I did a similar test.
There’s definitely something wrong with “Export as VLM” in the Mission Hub and opening/simulating this mission in Google Earth Pro.
The emulated Straight Lines mission slowly yaws from WP2 to WP3 while flying from WP1 to WP2.
Also when you change a curved mission with curves in waypoint settings, to a Straight Lines Mission in Mission Settings, the exported VLM mission will STILL emulate as a curved mission in Google Earth Pro.

As a newbe I do not know how make Litchi aware of this problem.

Your first video shows how direct lines wp1, wp2…, interpolate enable work.
Your second video shows how direct lines wp1,wp2…, interpolate disable work.
But my question is, how can you look at wp2, with a suspension angle of 30 degrees? It is not right. If you look at the next waypoint, then setting the angle is wrong. There is a poi for this setting.

I think I understand the confusion here.

The camera does not interpolate in a horizontal plane ( left or right )
it is fixed straight in line with the centre line of the drone.

So at waypoints with no curves, the camera will look ahead in the direction of travel
right up to the moment the drone has to turn to follow the path to the next waypoint.

The camera can only interpolate up and down between waypoints
depending on the camera angles that you have set for each waypoint.
The camera interpolation angles you set only makes the camera look up or down.

If you want the camera to make smooth turns to point to the next waypoint, each time, before it gets there,
you need to use custom ( wd ) and point the camera towards the next waypoint.

This is the interpolate that I think you are asking about.

Eg… at waypoint 17, set the blue arrow camera pointer to look at waypoint 18, or even waypoint 19

The drone will then smoothly " interpolate " … horizontally left or right …
to the next waypoint each time throughout the mission.

Here it does not matter if you use curved turns or not.

TNW Towards next waypoint means exactly that, the drone will go right up
to the next waypoint, before it has to turn.
Unless the next waypoint is in a straight line with the previous waypoint,
the camera will not smoothly turn to look at the next waypoint.

1 Like

I understand it. But the author does not work like that.

In his route, why “interpolate”, if the angle is set to -30 one for all points

VLM is a 3rd-party extension (not Litchi’s responsebility).
VLM generates a kml-file from a mission.
There’s either something wrong with VLM,
or
The way Google Earth Pro interprets the generated kml-file.

The suspension would be off otherwise.

At each point, you can set the tilt of the camera gimbal. There is a separate function for this.
Even the rotation can be set for each point separately.