Two Completely "Blank Missions" with 370 mission points

On Friday, I flew two missions of about 370 waypoints each. Controller is DJI RC Pro and Drone was Mini 3 Pro. Launch and start of mission had no problems…but once the missions began there was no camera click sound and the height figure for where picture was taken constantly flickered instead of the normal just coming on when a waypoint has been captured. After the first mission I shut down
both the drone and controllers and tried again. The same thing happened. I’m not immediately jumping to the conclusion that this was a software issue. It’s possible but unlikely that both micro SD cards were not properly formatted I have been using “Quick Format” for formatting them which up to now has never been a problem and the two cards were different brands. I’ve now on all 15 of my micro SD Cards fully reformatted (not “Quick Formatting”) them and then upon placing them into the Mini 3 formatted them again. The other possibility could be the Mini 3 Pro since I own two tomorrow I will fly the other Mini 3 Pro and I’ve reloaded the software in case it was simply a software corruption issue. However I’ve previously reloaded Litchi Pilot ver. 222 software often. Whenever I fly these missions I’m also flying using Litchi’s release version with either iPad or DJI Smart Controller and Mavic 2 Pro drone to compare quality of images and final results. One of the reasons I decided to be a beta tester was to see if the 3 Mini Pro was actually dependable enough for me to carry with my still camera gear on long walking trips into the glaciers of Iceland and other places…because it’s size and weight would considerably lighten my load. Perhaps the Mini 3 Drone just can’t take all the missions which are always somewhere between 360 and 530 mission points for the two sites I’ve been testing at. I will fly again tomorrow when winds are calmer and report back on the results using fully formatted cards, reloaded software, and two different Mini 3 Drones. I perhaps should have done the above changes one at a time to pinpoint cause of total camera failure but I’ll be leaving soon for work in the Dakotas and New Mexico and I want to find out quickly if it’s worth packing the Mini 3 Pro and using Litchi Pilot Beta along with my other drones. As an aside I’m wondering if someone can tell me if the color lookup tables etc. of Litchi Pilot are the same as release version of Litchi with the Mini 3 Pro there is a slight reddish cast on everything I shoot with Pilot but not when I just take stills with the DJI software. The release version of Litchi always gives me excellent color fidelity.

Could you have possibly have set your Path Mode to Curved Turns, which would negate any waypoint actions to be taken?

Thanks very much for your query. I do not think I could have done that since my
procedure has always been the same. Choose waypoint plan, it appears on screen then wait until drone and controller and satellites have connected properly then press takeoff button then press button to begin mission. If I had done what you’ve kindly asked if I had done what procedure must I have needed to follow to accomplish that? Thus far I haven’t been noodling in the interface so I don’t think I could have done what you’ve offered up as a possible reason. On another topic I’m wondering how many of the beta testers have flown 5 or 6 missions or more a week which are at least 360 waypoints and sometimes over 520 waypoints? I’m still leaning more towards Mini 3 Shutter not being up to snuff however could or should the software indicate somehow (or maybe the no click sound is the indicator) that the drone is not taking photos? I’m looking forward to tomorrow where hopefully I narrow down what may be a hardware and not software issue or by using two of the same type of drone and getting same results start leaning more towards beta software. Thanks very much for informing me about what the possible cause may have been.

Your start-up procedure for mission flight is not in question. Everything you do (choose mission, making sure satellites are found, etc) is great.

In the Mission Settings, there is an option for the ‘Path Mode’. It can be ‘Straight Lines’ or ‘Curved Turns’. If you choose ‘Curved Turns’ then Waypoint Actions (ex: Take Photo) are ignored.

Thanks for your detailed response, I have not done what you’ve described however I will check those settings to make sure it’s not set to curved before I test again tomorrow…thanks for a luminously clear explanation …on the release version I’ve used the feature but that was years ago just to do an iceberg.

Now I pretty much just do ortho mosaic photogrammetry. Thanks for taking the time for the explanation.

Sam I forgot to ask, if it was set for curved waypoints would that cause a constant flicker to occur of the height information in the middle of the screen? That as I’ve stated was what was happening…can anyone explain why it would do that? Thanks Again

I had the same issue one day. I didn’t recall having changed the flight path which was a repeated documentation of a monthly project.
Sam has the answer. Somehow it got set to “Curved turns” from “straight lines”. Problem solved!

I never went into the interface to make that change (curved turns)…it’s way too early to start choosing options when they haven’t even sorted out how to make manual shutter speed work at 800…however the work around is to set it manually in DJI Fly program then close that program (check force quit setting is still off) and you have 800 shutter speed set in Litchi Pilot when you open it…I reloaded program today (I do it every few days as it seems to become easily corrupted) and reformatted micro SD Cards and got two 370 waypoint missions and 2 520 waypoint missions with the same Mini 3 Pro that last time gave me the two blank missions so that leads me to believe that issue was with software related or micro sd issue but since I used two different ones micro sd cards and two different brands I seriously doubt it was them…I had another Pilot app anomaly however…at the start of the second 520 mission I pressed launch button and it rose straight up and flew to start mission without me touching the mission button to initiate it…

If you are willing to share those missions in question, users here will be happy to take a look at them and help diagnose them.

Thanks Sam, however the missions worked today perfectly and they worked perfectly prior to the one day of blank ones…what do you think they could ascertain if that’s the case. Not sure client would allow me to release them but if you think it would help I can find out. By the way I explained about “Force Quit being turned off” above which could lead to problems for others if they read the incorrect way I stated it in my instructions about setting the manual shutter speed of 800 and Lower in the DJI Fly app and then Pilot will not only open in 800 but you can then adjust settings without it reverting to Auto settings bug. Is there some way to change that above in the previous post above yours? My deepest apologies I’ve been distracted while typing by my NVIDIA and Ambarella stock information I’ve been digesting.

Here’s a question perhaps you can answer. Can code be written in such a way that over time it can begin to deteriorate? Or can you explain anomalies like the one that happened today whereby I launched and then without initiating the mission button the drone flew off and started flying it…when I’ve already launched between 20 to 30 times without that happening? I’m aware of operator error but could something like that even happen with what I’ve just described happened to me today? Why do I periodically get “H” the periodically floats around my screen but not always. Why once you hit the “Return to Home” and if you touch it again it gives you the option of “Cancel” and “Return Home” do the same thing and of course “Land” will just have it land wherever it is. For me I would like to see the ability to initiate return to home and then have the option to set it to something which would allow me to manually land…I assumed that’s what “Cancel” was for but twice when I’ve tried that it just continues to return home and that leads me to ask why it more often than not lands a few feet from my target…which may be the nature of how precise it can land…I’ve noticed I do have some stick control to make the actual landing more precise but it’s flakey it more precisely doesn’t work as precisely from one mission to another even when rerunning the same mission. I’ll leave this for now…I hope I’m not bothering you by my curiosity if I am please let me know and I’ll cease and desist. Cheers

Hi Often we try to find the most complicated answer to a problem instead of looking for the obvious ones.

  1. Is there enough Ram and SD card storage for the mission and data you are capturing?
  2. Is it a high speed SD card?
  3. Flickelring of displays is often due to a MCU struggling to deliver.
  4. Temperature: Lithiun batteries do not perform well at freezing and below so you may have a voltage drop affecting the drones ICUs.
  5. have you tried chargeing the drone at below freezing as this will destroy the lithium battery reducing its voltage.
    Regards Norm

Norman many thanks for your query. Here is my response to each question:

  • Is there enough Ram and SD card storage for the mission and data you are capturing?
    SD Cards Are Either Sandisk Extreme or Samsung Pro both Brands Are 128 GB or 256 V30 U3 A2
    I’ve always reformatted cards prior to flight the 128’s I use for the 370 way points and the 256’s I use
    for the 597 way point missions. Regarding ram question you must be referring controller ram which is RC Pro it’s more than sufficient and I only run Pilot when flying. By the way I’m aware of the importance of ram the machine I use for Metashape has close to 400 gigs with 92 terabytes of storage on site and backed up by two Synology servers with 80 terabytes each and a third copied to a bank vault stored drive periodically updated. I own 10 drones of various models and brands.
  • Is it a high speed SD card?
    Brands Are 128 GB or 256 V30 U3 A2 as answered above
  • Flickelring of displays is often due to a MCU struggling to deliver.
    My procedures have always been the same the rapid flickering occurred once during blank flights. When using release version of Litchi none of my stated issues ever occurred the only difference is I’m now using the RC Pro Controller and Mini 3 pro instead of iPad and Mavic 2 Pro
    Mavic 2S
  • Temperature: Lithiun batteries do not perform well at freezing and below so you may have a voltage drop affecting the drones ICUs.
    We’ve had the warmest winter in the History of Wisconsin this year. I’ve not flown below 42 far. and when it happened (blank flighs) it was upper 50’s to low 60’s far. I’ve done alot of flying in Iceland in Winter and never had issues…I’ve been a licensed drone pilot for over 8 years
  • have you tried chargeing the drone at below freezing as this will destroy the lithium battery reducing its voltage.
    I have not ever charged the RC Pro controller or any other controller or Ipad or. any drone batteries in anything but room temperature environment. As a professional photographer ( I’ve been doing photography for over 50 years.

Another thing I’ve previously forgotten to mention…the previous day and now each day I’ve flown afterwards it is evident that way points are being missed. When I assemble the photographs in Metashape 2.1 (latest version) there are white holes where no data has been written…I’ll check to see
if I’ve saved those missions and send you examples…by the way I still have FPL’s and CSV’s of my missions I can also send to you…what is best way to email them outside this forum…I don’t mind posting the photos on the site but not FPL’s and CSV’s this is a project on environmental degradation I’ve been working on for almost 3 years and I reiterate none of these problems has ever occurred with released version of Litchi. Thanks again for your query… I hope to fly Saturday with a different mission plan of one of the sites and see if that makes a difference… By the way I figured I’d do beta testing on Pilot because it had been tested since July but it strikes me to be quite buggy and it seems each time I fly another anomaly happens. I’ve only flown Ver. 222 and I look forward to a future release which is more robust.

Here’s a question not asked but I think perhaps should have been. What is the frequency of how often you take a waypoint photo? In all my missions I always have at least 3.5 seconds or more.

I also forgot to mention that prior to all this I noticed that the times I heard the camera clicks sound for each waypoint often varied and sometimes it was obvious by the delay in the click sound that a photo had been missed before I heard the next click. Often reloading Ver. 222 seemed to be a temporary remedy.


I guess it’s time to show you the difference in what Litchi Release Version and Litchi Pilot look like side by side. Litchi Release was done with Mavic 2 Pro/iPad, Litchi Pilot was done with Mini 3 Pro/ RC Pro
these were done less than 10 minutes apart. What your looking at is how the same Mission Plan came out without adulteration after being processed with Metashape 2.1

Photo 1 is Litchi Release Version and DJI Mavic Pro 2, iPad, Photo 2 is Litchi Pilot Mini Pro 3 and RC Pro…note color inaccuracy. Overall red cast and green cast along edges as well as missing photos. The composites were processed with Metashape 2.1. These composites of 370 waypoints ea. have not been changed in any way other than a reduction in size for viewing here…a picture is indeed worth a thousand words…I know a bit about color accuracy having set-up digital imaging systems for publication during the infancy of conversion from analog to digital for newspaper and magazine publishers. I only mention this because I sometimes think that some of the questions asked wonder if it’s user error rather than something else (it’s possible)…which indeed I guess they need to ask since they’re unfamiliar with me and where I’m coming from with regard to reporting bugs…All The Best, I forgot to mention this beta testing has been a bit arduous which is why when I do it I also do it with equipment and software which works at the same time I’m testing the beta version so that I’m getting my work done for the client as well as the testing.

The two drones that you are using handle waypoint missions completely differently. The Mavic 2 Pro is able to load a mission (99 waypoints at a time) into the drone and then fly that mission and take photos completely autonomously (without a connection to the remote). The Mini 3 Pro is a “virtual stick” drone where the mission is not loaded into the drone. Instead, the mission is kept on the controller and virtual stick commands are continuously being sent from the controller to the drone. Missions run using virtual sticks are prone to momentary disconnections depending on the distance and terrain between the controller and the drone.

Have you loaded your flight logs to AirData and had a look at the “Signal Map” for this flight? That would tell you something about the signal strength during this mission. It looks like most of the holes are near the top of that image. Were you standing at a location near the bottom of that image?

I would hope not!

Thanks very much for your explanation of the two methods …as you can see there are no trees
or anything else which would corrupt transmission nothing about 3 feet high especially this time of year when no growth takes place…it is also rural with nothing nearby which could corrupt the signal and the distance from the controller is not very far away I’ve never measured it but suffice it to say that at all times that small drone can be seen with the naked eye. Tomorrow I’m going to compare results from the Mini Pro 3 and Air 2S…do you know what method they use for that one? What do you think about the inaccurate color? Do you think it’s Mini 3’s shortcomings or software related? Thanks again for explaining the difference in how they handle waypoints but if the short distance from controller to drone is what causes this I’d be quite surprised…Here’s another interesting aspect I’m just now thinking about…the other site the drone is much further away both in flying the waypoints and the distance it needs to travel just to start the mission and it’s had considerably less (missing images if any) when it’s flying but I still notice a variance in the period of time at both sites between the click sound of the camera. Later flights seem to have more difficulty but there is ample empty space on the cards upon fining the missions.

Have you loaded your flight logs to AirData and had a look at the “Signal Map” for this flight? That would tell you something about the signal strength during this mission. It looks like most of the holes are near the top of that image. Were you standing at a location near the bottom of that image?

I’ve forgotten to answer your above question…I will do what you suggest, however I have looked at signal strength periodically prior to flight and it always been bright green.