The air2s camera goes crazy during the mission

https://flylitchi.com/hub?m=dQsIn2mcaB

Good morning everyone.
I have another problem with missions, but it’s definitely my mistake.
As mentioned in another post, I loaded Litchi on Dji Rc Pro with Air2S. (Please you see the Link up ) I did this mission and started from my house, up to the 3rd wy point everything is ok, the camera points well, but from # 3 onwards, I no longer understand anything and where I went wrong, the camera (and I also think the drone) seems to go crazy. What can it be?
Thank you.

I posted a thread on this very topic after both my Mavic Pro 1 and Mavic Pro Platinum cameras danced about wildly during Litchi waypoint missions. A drone flier responded that such camera jitters kick in when the signal connectivity between the drone and its controller starts to break up due to interference or distance of the drone from the home point.

The simple solution that stopped the camera dance for both my Mavic Pro drones was simply to power off the controller during long Litchi waypoint missions, before then powering the controller back on when the drone is due back from its mission.

Now, I do realize that your Mavic Air 2S uses DJI Fly and cannot have its controller powered off during a waypoint mission because the “virtual sticks” protocol used by DJI Fly drones requires continuous connectivity between the drone and its controller. I still decided to share the work-around that is applicable to older Mavic Pro drones, simply to highlight that the dancing camera syndrome is NOT related to any fault with the drone or its controller, and COULD be resolved in the case of your drone by keeping your Litchi waypoint mission flight paths within close enough proximity to ensure there is a strong signal link from drone to the controller.

1 Like

Thanks for the reply. But you must know that litchi on Dji Rc pro requires that, before opening Litchi, it must be forced to close the Dji Fly app otherwise Litchi does not work well so it has no signal from it but only from Litchi. I don’t know if it’s a Litchi bug on rc pro or it’s something I do wrong. Anyway, I have to acknowledge that the mission is quite far away.
Giuseppe.

My guess is that even with the Air 2S drone you fly, that dancing camera behavior occurs only when the signal between the drone and its controller is broken even for a moment during a Litchi waypoint mission that takes the drone far away from the home point. I am pretty sure that neither Litchi nor DJI Fly contributes to that jittery camera issue.

When the cameras on both my Mavic Pros danced about wildly I at first thought there was a problem with the drones that might need repair. Then I received a helpful forum response pointing out an interruption in the drone to controller signal as the possible culprit.

Sure enough, since I began the practice of turning the controller’s power off during the early part of longer Litchi waypoint missions flown by my Mavic Pro and Pro Platinum, before later turning the controller on just for the final approach and landing, the dancing camera behavior never occurred again even once with either drone.

Since with your Mavic Air2S, the controller must be powered on and connected to the drone for the entire Litchi waypoint mission due to the requirement of “virtual sticks”, a good test to run would be to launch your drone on a couple of much shorter Litchi missions during which there is a strong connection at all times between the controller and the drone.

If the camera remains stable with no observed jitters during such shorter flights, then simply reducing the furthest distance downrange for your saved Litchi missions, so as to keep the drone nearer home where the controller’s signal is stronger, ought to be the best way to keep the camera from going onto that unstable condition during future flights.

no friend, unfortunately the proof that you know me by saying fire, I had thought so too, I redid a new mission with a range of 400/500 meters and the signal was almost always at maximum, the same mission I did it with both video that with photos, and I also wanted to do the test with the rc n1 radio control (gray) and with a smartphone, but unfortunately the camera errors always repeat themselves, I am really very disheartened now, I have 3 paid licenses of lychee, for ios , android and smart controller and I don’t want to have these problems, I really hope it’s my setting error.
Giuseppe

Ah, I see. It sounds like my idea that it is a range issue is not correct. If you begin to suspect that the problem might be with the drone and not with Litchi, then I highly recommend the Mavic Pilots Forum, where many owners of the same drone model share ideas most helpfully.

https://mavicpilots.com/forums/mavic-air-2s-discussions.189/

no, I am more convinced that it is something wrong with the mission, it is not the drone because I have already done this path with Dji fly and I do not remember having had these problems. litchi is a very valid and powerful application, but it is also very meticulous with certain parameters, in short, it is not the small software for everyone, you need a lot of experience and above all continuity to use it, just to treasure the mistakes that are made . Unfortunately, I am an old admirer and owner of lychee, but I am limited to using it because I always travel around the world for work, I have it from the first versions.

From the Litchi user manual: Attaching a video to a mission and disabling the ‘Private’ checkbox will make it appear on the map for other users.

However, if you simply want to share your mission with us without attaching a video, uncheck the “private” box like you already have, then copy the URL from your browser and paste it here. We will then be able to access your mission.

https://flylitchi.com/hub?m=dQsIn2mcaB

Oh, it’s easy . :grin: thank you

While I don’t see anything in your mission which would cause the camera/drone to yaw like I saw in your video, there are a couple issues that I did find:

  1. Your mission has the “Path Mode” set to “Curved turns” yet you defined a “Start recording” action at WP 3 and a “Stop recording” action at WP 15. Those actions will be ignored because of the curved turns setting.
  2. You have two POIs defined and most waypoints are set to point at either one of them. However, your “Heading Mode” is set to “Auto (TNW)” which will cause the drone to ignore the POIs. This isn’t a problem if that is what you want, it is just a curiosity.

You are much braver then me to fly a long mission like that over a populated area. I’m sorry that I am not able to pinpoint an issue with your mission. I would do more testing (with shorter missions) to see if the issue is repeatable.

1 Like

A friend with the new version 4.25.0 is no longer relevant. Your drone will fly smoothly without connecting to the remote. Whether it’s on or off

Just activate in the settings “dji interpolation …”

Does NOT work with the Mavic Pro

Where is it said. Pro is also a dji go4 drone

In the ‘What’s new’ section.

Well, okay, I still don’t have mavic pro and it works for me :slight_smile:

Hi TriBar, do you have any ideas for my problem?
Giuseppe

In my opinion it’s a typical ‘issue’ with DJI Fly drones that use VSC (Virtual Stick Commands).
VSC is still very different from manual flying !

The number of control signal bars in the top of the screen is just an average, it doesn’t tell anything about complete signal interruptions, especially brief ones.

According to the Air2S specs the FCC transmission range in urban landscapes is approx. 1.5 - 3 km, and the max range is 12 km.
The max CE range is 8 km.
8/12x 1.5 to 3 km = 1 to 2 km
(All theoretical)

Your ‘problem’ starts at a distance of approx. 1.3 km.

Visit the harbor and fly a short mission at the spot for the best possible footage.

Have a look at this topic:

Thanks for your response TriBar.
This is another problem that we had already talked to another friend, precisely that of the Virtual sticks, so I wanted to do another test, on my home and with a range of 4/500 meters and keep in mind that I live in the countryside, so as almost zero disturbances, it did the same to me indeed, at 3 wypoint it even stopped and did a mini orbit type ellipse, so I pressed the c1 pause key and then c1 again and so it started resuming the mission from that point. Did you take a look at the mission if everything is okay? I really hope that this is the problem and nothing else.
Anyway, Dji is complicating our life more and more, with the excuse of wanting to make it safer, he is taking away too many things from us.
Giuseppe

I can’t see anything wrong with your shared mission.

You have set ‘Heading Mode’ to ‘Auto(TNW)’ and ‘Gimbal Pitch’ for all waypoints to ‘Focus POI’.
This means that the camera will tilt at the corresponding POI, but NOT yaw at the POI, which means the POIs will never get into the center of the frame.

It’s a bit unusual to set up a mission like this.

In order to get a POI in the center of the frame ‘Heading Mode’ should be set to ‘Custom(WD)’.

I made some changes to your mission and saved it under the name ‘capripiu-01’, here the link:

Another thing you could try is disabling object avoidance, however it seems unlikely the sun was messing with the object avoidance sensors during this flight.