My experience so far . Update 4 -Build 155

Samsung Galaxy S9Plus, Android v10
DJI Mini 3 Pro FW v01.00.0500
Litchi Pilot 1.0.0_BETA-dji(115)

-The app crashes when location is turned off.
-Camera View sometimes freezes then disappears after switching to map view and back, you can still switch between camera view & map view, but camera view is black except for the UI and gone in the lower right corner in map view, the UI keeps updating (see screenshot).
-When “Finish Action” is set to RTH and the last waypoint is within 5m of the Homepoint, the Mini 3 Pro will just Hover.

-How to focus with Mini 3 Pro ?
(Camera is set to AF in the DJI Fly app.)
The drone does focus once before take off but that’s almost always at a point nearby so the main video is out of focus.

-Location of the flightlogs:
CSV files not supported by AirData-UAV (yet).

-When “Finish Action” is set to RTH and the last waypoint is at 30m of the Homepoint, the Mini 3 Pro will just Hover.
-Stay For 15s at 1st waypoint in the hope the camera will focus
-Start recording before take off: Refocus occured at WP1
-Start recording at WP1: Refocus occured

2023-07-02 @ 10:06
Litchi Pilot 1.0.0_BETA-dji**(116)**
-FIXED: The Litchi-Pilot app crashes when location is turned off.

Litchi Pilot 1.0.0_BETA-dji**(116)**
-FIXED: The Litchi-Pilot app crashes when location is turned off.

Interpolate works
Focus POI works
Disabled works

Auto (TNW) not tested
Initial (ID) not tested
Manual (UC) Works
Custom (WD) Works

None not tested
RTH Fail
Land Fail
Back to 1 Works
Reverse not tested

Manual speed override does NOT work

Low Battery RTH Works

NO Flightlogs are recorded in:

S9Plus (Android v10):
No problems using build in screen recorder
Screen Mode set to “Basic”
Screen Resolution set to:

  • HD+ (1480x720) → Freezing problem solved
  • FHD+ (2220x1080) → Live video freezes
  • WQHD+ (2960x1440) → Live video freezes

S7Edge (Android v8.0.0):
-When using AZ-Screenrecorder the app crashes.
-NO Live Video freezing


Autofocus should normally be good enough, at least it was for us when testing. Litchi itself does not control the camera focus, it is controlled by the drone firmware. We will try to add tap to focus so you can manually trigger the AF.

Land/RTH finish actions not working: will fix in next build

Flight logs are not supported yet, will be added soon

Are video freezes only happening when using a screen recorder?

1 Like

In my opinion that’s a must.
As long as the drone is moving it will never refocus by it’s own.
I solved it by adding the action “Stay For 10s” at WP1, this triggers a refocus.


With the S7Edge using AZ-Screenrecorder there was no video freeze but a total crash of the phone. The screen recording footage wasn’t even on the phone.
Android v8 has no build-in screenrecorder

With the S9Plus freezing does not occur when the Display resolution is set to HD+ (1480x720), with & without the use of the build-in screen recorder.
Strangely the recorded footage however is in FHD+ (2220x1080) resolution.

1 Like

This button should toggle the Map View between “North Up” & “Free”.
It toggles to “Free” but NOT back to “North Up”, the symbol changes but the map doesn’t rotate back to North Up.

The compass icon is for ‘Compass’ mode: the map auto rotates based on the mobile device orientation
The square+arrow icon is for ‘Follow’ mode: the map automatically follows the drone (or mobile device if no drone)
The hand/finger icon is for ‘Manual mode’: it is displayed when the map has been manually moved and is no longer in ‘Compass’ or ‘Follow’ mode

When you tap on the button it should toggle between Compass and Follow mode

Ok, clear, that’s slightly different from the compass button in the regular Litchi app.
To avoid misunderstandings an update of the meaning of the symbols:


2023-07-08 (Build 121)

S9Plus (Android v10):
Still multiple Video Feed issues (Freeze & non at all) with & without using the build-in screen recorder.
A few times the Litchi Pilot app did shut down, after reopening it, Live Video Feed is gone. You have to Force close the app & restart the controller (N1) to get up and running again.

Tap to Focus works, also with the wide angle lens.
I can’t get Manual Focus to work

The Map view zooms further out every time you switch between Map View & Camera View
When you load a mission while in Camera view, the Map view isn’t zoomed in on the mission boundaries (see screenshot).

Importing a flight plan locally works, but it took a while to figure out how to do it.

Flight logs are stored in:
They are NOT compatible with AirData UAV

Maximum distance between the Homepoint & WP1 is ONLY 500m.

1 Like


Causes Several automatic refocus actions during a flight.
-The refocus action itself makes the footage unusable
-Depending on the gimbal pitch angle, after an automatic refocus the footage becomes unsharp in the distance.

In the Litchi Pilot app let the user switch between MF & AF, don’t use AFC.
Let the user toggle between all 3 of them (MF, AF & AFC).

During one flight Downlink was lost causing the Flight Mode switch to P-GPS (Bypass) and the drone to hover.
Signal Loss Behavior was set to RTH.
Not exactly knowing what was happening, after 1.5 minutes I pressed the RTH button on the controller (see screenshot).
Shouldn’t the drone return to home by itself or perhaps even continue the mission ?

1 Like

We did different tests to test the loss of signal.
The first was to shutdown the RC while flying in waypoint mode → the RTH triggered directly and after starting the RC the signal came back instantly.
The second was a long range test with 2 waypoints → RTH triggered when signal was completely lost at approx 500m distance. Signal recovered as soon as the drone was brought back into the RC’s range.

In your case, most likely you did not loose the signal entirely for long enough.


Nov. 2023 - Build 155

I miss the mission setting “Rotation Direction” and the associated waypoint setting “Rotation”.