[OPEN BETA] Litchi Pilot

This app will also be in other languages, for example in Czech language?
Litchi is great, I would like to continue using it, but without my language, it loses its meaning for me…

I checked it. No DJI Apss are running and I still don’t have video… Any further Ideas?

Force STOP any/all DJI apps in the device settings:
(Force Stop is NOT the same as Force Close)
Settings > Apps > DJI app > Force Stop.

Litchi Pilot Build 222_Shutter Speed jumps to Auto instead of 800

Miin3 Pro, RC-N1 with S20FE5G: I’m having 2 issues with Litchi Pilot.

#1 Planned missions repeatedly stop mid way ( waypoint #8 of 16 )with warning " Flight interrupted: The flight mode was changed " when I haven’t made any inputs. I tried to resume with Start Flight at #9 the next waypoint, still no change, will not resume. When I manually flew to next waypoint (:46), I tried Start Flight #9 again and it finished the mission. This has happened on 3 successive flights with full signal. Latest updates on all devices involved.

#2 Litchi pilot does not connect or upload flight data to AirData. Only DJI Fly flights upload, nothing from Litchi Pilot.

Suggestions? Thanks in advance for any help.


The signal strength indicator shows the video-feed signal strength only, NOT the control signal strength.
Besides that, even with 5 bars there can still be very short signal interruptions.

Manual flying appears to be much less sensitive to control signal interruptions.

Most likely there are control signal interruptions. Have a look at this thread:

Page 43 in the Mini 3 Pro User manual.

According to @vico (administrator) dd july 2023:
“Flight logs are not supported yet, will be added soon”

Augmented reality shows the home point and POI’s realtime in the video feed.

A number of things can cause this message to appear. One of those things is being in or near an “Enhanced Authorization Zone”. Check using DJI Fly to see if you are near one of these zones.

Thank you for the detailed response and references. I need the programmed mission to work for search & rescue operations as efficient covering of a grid is difficult at best while manually flying. The mission interruptions occurred at two different flying sites with very little if no interference and none of the flights were anywhere near controlled airspace ( I was more than 5 miles from the outer edge of class D airspace) and I checked for any other restrictions before flying such as a TFR.
Thanks for the information regarding AirData not being supported, hopefully that will be along soon as the .csv files are necessary for the SAR work I do.

None of that matters. You need to check for DJI’s authorization zones. They don’t always line up with controlled airspace.

Thanks Wes, but one of the two sites I’ve flown frequently for over a year and always check first for changes. I just checked both sites to be sure and no restrictions.

I am automatically translating Japanese and writing it.
I’m also having trouble with the problem of stopping mid-mission.
The aircraft flew in two rural fields unrelated to controlled airspace, but both flew for about 5 to 7 minutes before automatically stopping.
After landing, even after restarting the android and flying, it still stopped midway.

I bought a Samsung A54.

Nice phone and works well with the Litch Beta…

We are preparing a Flight plan via CSV-input for the Mavic3e. We need to input a positive camera-tilt angle, but the mission hub cuts this back to zero, although the m3e is capable to look „upwards“. Is there a way or workaround, to let the M3e camera tilt in positive angle?

You can input a positive interpolation angle. However, the “tilt camera” action must be 0 (zero) or less.

Thank you, we will give it a try. May be, an „upward look“ towards a POI higher than the actual drone position could work as well?

Thx, Albrecht

Has this been rectified? Will the M3E continue the mission upon loss of signal, or does it still RTH?

The DJI waypoint engine is not supported yet but we hope to add support soon.

The newest update of Litchi Pilot has completely broken the Android app. When I open the planing mode, it is impossible to return back to flight mode. Planing mode crashes constantly, making waypoint planing impossible.
It is not possible to load saved missions into flight mode view.


This version needs to be rolled back and the previous again made available.

I am now looking for alternatives.

Not working for me all of a sudden- updated last week and worked fine. Now when I open the app it jumps between the world view and my location view then crashes.
Get the error message:
“Something went wrong with Litchi Pilot
Litchi Pilot closed because this app has a bug.
Try updating this app after its developer provides a fix for this error.”

Tried clearing cache and app data but no joy?

The return back to flight mode should be fixed in the latest build 286, sorry about that!

Crashes should not happen normally however do check that you have google chrome browser installed and set as default browser, otherwise Litchi will use the android webview to launch the Hub and it has known crash issues.

You should be able to load a flight plan after selecting it via the ‘load’ button on the left side of the screen