Moving the homepoint

You can only move the home point while flying, I know. But even while flying it’s near impossible, I keep on scrolling the map around.

Litchi seems to expect me to hit the 5 pixels of the homepoint with my big fat fingers while the phone is embedded inside the controller. Not easy.

Am I doing something wrong? Is there a “move home point” button somewhere, or some way to be sure that you move the homepoint rather than the map if you… doubletap then hold or whatever secret combination?


@Marten_van_Wezel, enable Dynamic Homepoint in the Aircraft settings. This is from the settings portion of the User Guide:

Dynamic Homepoint : When enabled, the home point will continuously be updated to the current location of your mobile device. Recommended in Follow mode.

1 Like

Yea that’s not a bad tip as a proxy, but in my situation, landing where I took off is not ideal (it’s too small). Instead I would normally want my home point to be in as good an open space as I can find so the chance of a safe landing purely GPS based is likely.

Agreed I could normally walk there but I prefer to set it full manual.

1 Like

@Marten_van_Wezel, I am not currently aware of another option in Litchi, but other users may have ideas.

Just a quick update, I tried again and it is really very very frustrating. Having a mobile phone held up into a controller (since you have to be flying it can’t be offline) and then trying to poke at a 4mm circle with one finger while you hold the remote in another is pretty much impossible.

Litchi team this really needs to be fixed… many many potential ways. A set homepoint button, double tap on screen, tap and hold…

1 Like

I normally don’t move my home point but I tried as a result of your post. I find it no different from moving a mission waypoint. It’s not the easiest thing to do but not impossible. If you press and hold, the map will move up slightly, exposing the home point just above your finger tip. Then you can drag the home point to a new location. If the map does not move after you press and hold, it means the home point was not selected. Then try the “press and hold” again.

I fly using an iPad mini, so I admit that might make it incrementally easier.

1 Like

Yes I have just a standard phone, so the homepoint is really small, not to mention that trying to accurately poke at any small item on a vertical screen is very difficult. Try picking any letter on your computer screen (assuming you’re on a laptop or desktop machine) and poking it exactly and not the letter next to it. Can’t do it dependably, and doing this while your drone is hovering in front of you is aggravating.

Of course setting/verifying a sensible homepoint should be part of anyone’s preflight list, but this basically makes it too annoying for me.

1 Like

I suffer from touch screen dead fingers. I have to use a Stylus for most everything. You may want to check into that avenue.
My hands spent decades doing fine construction work but Touch devices cant read my touch, Unrelated is My daughter which Cant wear an Electric Watch. Will kill it in a day.