Litchi mission stops for 2 minutes at waypoint

I have been using Litchi with no problems for years. Suddenly, the drone is stopping for two minutes at the first waypoint. From that point on, it goes along just fine through the remaining waypoints. I tried deleting the first waypoint and then putting it back in, but it still does it. Could just re-enter the mission from scratch, but I would like to figure out what is going on. Here is the URL:

1 Like

The link doesnt work for some reason. It bounces to the Mission Hub screen, but doesnt open a mission.

Does this happen for just this single particular mission
and no other missions ?

Unexpected stops could be due to the collision sensors’ false triggering when the sun is low in the sky. If your altitudes are set well above ground obstructions and terrain, simply disabling all collision sensors may prove effective as a solution to those unexpected stops. It also helps to run a calibration on those sensors even if they will be disabled during waypoint flights, though I have no idea why that is true.

If that mission works for you, in the hub uncheck the private box.
Let us know, I want to see it.


Sorry that I forgot to uncheck the private box. I just did that. The drone consistently pauses at that waypoint, each time I run that mission.

Nothing obvious stands out in the mission or waypoint settings. If you are willing to share a flight log, that might shed some light on it.

What are you flying?
I will look at the mission soon.

Rod …

I have the csv file. How do I share it? I am flying a DJI Phantom 4 Pro.

Here it is: flight log

I need to do some checking. That might not be the right one.

Yes. That’s the right one. The mission stops from 2:45 for about 2 minutes.

P4 helps. I noticed way point 2 and 3 was cruising speed.
Are going to record videos or pictures?

Rod …

I could upload the video, but it’s a large file. What might the video tell us? When the drone stops, the video appears as you would expect: the camera was aimed constantly in the same direction for a while; then I panned it upward.

P4, @Mad_Pup may have a good theory, I know nothing about P4’s.
Did this same mission work before?

Taking video, you need the curve size set to any number than zero. It will pause there.
But you can’t change that on the first and last way points.


Could it be that the drone stops in the air while it waits for the remains of the mission
data to be up-loaded into the drone before it will continue the flight ?
= Slow data connection with the controller.

Not with the Phantom 4 Pro. It uploads the whole mission before take-off.
But, good point for thinking about it @archer

1 Like

Yeah … right !

Ok, I ran your mission in Google Earth.
Why have you set waypoint 1 at 120 metres ?
Why have you set two waypoints at each corner
where you only need one
and some curve sizes are set to zero, which makes the drone
slam into corners at 30 Km/h and rotate instantly.

and you are jumping from cruising speed to 30.8 Km/h.
You also need to set interpolate to minus 14 degrees on all waypoints
so that you do not have 50% sky filling your video.

I did not find any reason for the drone to wait at waypoint 2 for any time,
except for getting over the shock of launching at waypoint 1 immediately
into 30 Km/h.

The drone is stopping at waypoint 2 because it is reluctant to continue the
mission because it knows that it is going to get a good beating.

1 Like

Did you see anything that would be helpful, when you ran the mission?

Would any of the questions you asked explain the issue that @cinclodes had with the mission?
All of us have had missions that didnt operate as expected. Sometimes, we are able to diagnose the issue and correct the settings. Other times (like this one) we need help from fellow pilots.

Constructive criticism is one thing, if it helps with a problem. But, I think @archer is out of line with his comments.

1 Like

Ok, tell him what you think is wrong with his mission.

1 Like