Litchi keeps closing⁸

I have been using Lichi on a Samsung Tab A flying a DJI Mavic Air. Lichi will not run, it closes itself out as soon as it opens. I read on the forum:

Known Issues in Litchi 4.26.2 on Android:

  • Startup crash on some android devices (Samsung A13, Moto G Pure, etc). This is a bug in the latest DJI SDK version, we will update Litchi as soon as DJI fixes the crash. If your device is affected, please use [4.25.0]

If I can’t open Litchi how can I find the version number and how can I back it up?

You should be able to go to Settings on the tablet, then go to Apps.
Select the Litchi app and it should show the app version.


How long have you been using Android with Litchi?
You know about DJI always running problem in the background on Android’s?


Thanks it shows I am using Litchi 4.26.2-g. How do I get a older version of Litchi? If I click download, I just get the same one?

I have always run on Android, last 3-4 years. DJI app works. Litchi worked until recently.

1 Like

You could contact Litchi-support and ask them to send you a download link for a previous version that worked on your phone. Ask for the version 4.25.0 like it suggests in the Known Issues.

After installing a previous version, make sure you Disable ‘auto update’ for Litchi in the Playstore app

1 Like
1 Like

Thanks Sam, I emailed Will see what happens.


Have you tried the link to 4.25.0 in the previous post?

1 Like

It’s the link for 4.25.0 that I am looking for.

Yes. And that link was in the previous post – a couple posts up now. Hover you mouse over the “4.25.0” in the response by “Hello2”.

1 Like

Thanks, I was able to download and install the apk file. It now shows ver4.25 and seems to be working. I will check it out. Thanks again.

I have a similar issue, but the link doesn’t seem to work unless you bought the app from the Google Play Store. However, I use the version from the Amazon App Store. I have contacted support, but they couldn’t help. What should I do?

Looks like your NUU X6 Plus isn’t compatible with the latest version of Litchi.

I think it’s highly unlikely Litchi would not provide you with a link to download version 4.25.0-a if you show them proof of purchase.