Litchi Follow Mode

Is there something I am doing wrong or is it a bug?
First I was 82 ft high to clear all obstacles. First I was on a 150’ leash and Subject (me) at 25’. Later I shorten the leash to 100’ and then again later I set the Subject to 10’ to keep from running off the bottom of the video.
I had shot a video earlier and posted it with the drone following my Jeep. It almost seems I was walking to slow as the drone seemed to hunt all over the place though it kept me in sight.
I have a long video posted on YouTube showing the problem

Here is a clip of the track

1 Like

I have been using my 10" Lenovo Tablet to run the drone but today I tried my Motorola phone to test and came up with exactly the same results.
I am locked onto 23 Satellites just for more info.

Okay so here is another test I did from my Jeep at between 10-12 mph with the same follow settings as my walk in earlier posts. I even tried to trick it on some tight turns. It performed quite well.
Here is the video link on YouTube

Here is the nice smooth track from the video above

You have presented a very detailed description of your troubleshooting of Litchi’s “Follow” mode. I haven’t seen anyone else go through all of the steps that you have shown us. Thanks for that.

I fly using an iPad (with no GPS) so I have not attempted to use the “Follow” mode. Therefore, I cannot confirm what you have shown us. However, it would seem that you have found that there is indeed a minimum speed limitation for this mode to work properly.

I am watching this thread to see if others who do use the “Follow” mode share your experience.

Thanks for the compliments. :slight_smile: My background is retired computer tech and therefor lots of tech support. I hate it when people say “It doesn’t work” then make support dig the details out of the person.
I think it is important for everyone to take an interest and help support as much as we can if we want to see a great product like this succeed.
Happy flying!


I read somewhere tonight that the software needs movement at 1/m second to work. That works out to about 2.24 mph. I was walking at just under 4 mph. Maybe I got lazy and slowed down. I will try a faster walk tomorrow and see what happens.

Have a look at this topic:

Thanks but, I do have the services turned on and have tried it on both my Android Tablet and my Android phone.

Okay I tried a new test today. I used the follow mode but not the Course Tether mode. In other words I set the follow course to SE and left it there and the drone followed me perfectly


If nothing else, you are getting plenty of exercise doing all of these tests.

1 Like

I found one interesting problem with litchi location gps. For more accurate work, you need to turn off the “improvement of google location”, while the accuracy becomes about 2-3 meters.

Of course. Indeed, in this mode, the drone does not need to fly around you when you turn around. It gets darker, even in leash mode I get good results

Well if you look at my posts above you will see how mine wanders at walking speed when on leash but not when I drive at 10 mph. I think there is a small glitch in the software.

I’m talking about this to you. My phone showed gps accuracy of about 10 meters. If you turn off “google positioning improvements”, then the accuracy approaches the value of 1 meter.

This is actually logical, because the drone does not use the signals of cell stations, and the phone is unnecessary

I think litchi is using gmaps data incorrectly. The gmaps app itself works fine, but litchi may or may not work.