Litcbi app crashes everytime i open

Every time i open the app it crashes. I have deleted it and reinstalled, it then tries to intall dji database. It get to 100% then crashes.

Hi Josh, there is apparently a bug in the current release. Try a earlier version of Litchi until the current bug is fixed.



Just curious if anyone is having the same issue as I am? And what can I do to fix it? When I open the app it closes almost immediately it was working perfectly fine a week or so ago now I can’t even use the app! I’ve deleted the app and redownloaded it multiple times it’s just not going to work!


(App keeps closing - #2 by vico)




Check Known Issues with current release versions

@Steve_Amerson I download the version someone above posted…took it outside and it worked fine the 5 min I used it…left for a trip and tried to use it yesterday and it did the same thing as the other version did…app would close immediately

@Josh1, sorry about the trouble you are having, is there any chance that you downloaded the same version of Litchi as before? This would definitely have crashed again, but an earlier version should not be causing problems. If you definitely had trouble with Android version 4.25.0 then report this to Litchi. @vico is someone that you might be able to get help from as well as report your issues with version 4.25.0.

Sorry maybe a stupid question but where do i find the previous version 4.25?

no it isn’t a stupid question

If your device is affected, please use 4.25.0 Click here!

Okay I’ve tried the link, it downloads but when I try to install it says invalid package

“Okay I’ve tried the link, it downloads but when I try to install it says invalid package.” Hello @Mike8, since this is the Link posted by vico in Administration, I am unsure what the problem is. Try addressing Litchi Customer Support or @vico directly with this problem for the best advice. Thanks

I have the same problem, I tried to reload many times but no luck. I will delete it forever

first uninstall Litchi from your device then use the link to install the older 4.25.0 version and it should work