I need Help With my Mini2 and Litchi App for IOS

No Matter what I try and do I can not get the mission to take effect on my Litchi App.
I create the flight path on the Mission Hub web page, it is auto download to my iphone 8plus.
I put the aircraft into the air, but when I press the play button it tells that the drones is not connected. Yet all the reading at the top of the screen say I am.
Please tell me what I am doing wrong. IOS version 14.6 > I have latest patch in my drone…

From the Online User Guide:
1.Make sure no DJI-based apps (including DJI Fly, DJI Go and other third party apps) are running in the background. If there are any, close them
2.Start your drone and remote controller if you are using one, and let them initialize for a few seconds
3.Connect the remote controller to the mobile device using a cable. For Wi-Fi based drones (Phantom 3 Standard/4K or Spark), connect to the Wi-Fi network of the drone instead
4.Start Litchi

Thanks, I realize the could be a conflict with DJI Fly App so it is not loaded.
I am using the DJI controller that came with my Mini2 Drone.
I did start the Drone first
I then connected up the iphone to the remote with the cable provided.
Then connection to the drone completes with no problem.
I try flying the drone from FPV position – no problem, have a picture and all telemetry is running just fine.
I then switch to waypoints
Load my mission created on my Windows system.
No problem so far.
Everything is now set apparently. This is a very simple mission using 3 waypoints at an altitude of 30 feet or 10m . there no obstacles in my flight path.
Using the joysticks I start the drone and elevate it to around 4 feet.
Then I press the Play button, and that is where it all falls apart. It says I am not connected, which is false and that Requirements not met error comes up, no matter what I do the Waypoint mission will not start. Does that help clarify my problem?

What version of the Litchi App are you using?

where do I find the version #, I just downloaded this a few hours ago

Found it Version 2.12.2

“Requirements not met error comes up”
Do you have at least 10 locked satlites and/or did you hear the spoken message “Home point updated, please check it on the map” ?
Was the drone in Normal-mode, not Cinematic or Sport?

The setting for cinematic mode is that the problem?

Probably, something is missing or not set correctly. That’s why you get the message “Requirements not met”.

That was it. it would be helpful to let us know that is the problem in the App, something that simple.
Thank you for all your help… Chris

Litchi merely displays the messages it gets from the DJI SDK (Software Development Kit). Apparently DJI generates the same message for different scenarios. Nothing Litchi can do about this.

None the less, the Litchi software is very impressive.

Tri bar, much appreciated for your very valuable feedback. Please don’t assume that people are ignorant but just need a little shift for assistance

Hi Jim, are you DJI Mini2 drone pilot too? If so, what can you share on the the follow me option in the Litchi IOS option, as mine does not appear to work, so, I am guessing I am doing something wrong.

What seems to be your problem mate?

Is the Follow me option based on optics as in the drones camera on a subject only, or is there a secondary option that depends on the drone’s controller position in the Follow me Mode. When I tried to use it , I could not find a method to select myself as the drone’s optical subject. I was no more than a couple of meters away from it. I tried using the Follow settings, but the parameters they provide do not seem to have anything to do with an optical subject. Just a profile for layout and behavior. Sorry if I am bit verbose, but I am trying to understand this technology as I have plenty of uses for it. I thought a green box was suppose to appear and that is what you locked your subject to. I never did see any box.

‘Follow Mode’ uses the geographical position of the connected smart device to follow and point the camera to.
So ‘Follow’ does not work with smart devices without a GPS receiver, like an iPad without cellular.

If you want to follow something other than the controller then select the tracking option, where you can draw a box around the object you want to track using a pinching motion with 2 fingers

1 Like

Sorry for my ignorance, but I see now, that the Tracking option and the Follow me option are two entirely different functions.
TriBar, I was using a smart phone with both cellular and data plan. This was attached to the controller when I was trying to to test the option. I moved, but the drone did not respond. I will try again and shorten the distance from the subject in the Follow settings.
On a different note, does anyone know why the telemetry in Litchi seems more accurate than DJI Fly App?
I thought that SDK was based on the Fly App. The example I am thinking of is the height telemetry, at low altitudes the DJI app is inaccurate, but the Litchi app seems considerably more accurate. Would this be a settings issue. I like to confirm data and using two different software packages, which are loaded on my iphone and of course only one is loaded at a time. I would expect the telemetry to be identical in its interpretations. Apparently this not the case, why?
Thanks for all your help…Chris

I should also mention that both the DJI Mini2 and my Iphone are fully patched with their respective updates.