I can’t get my Mavic 2 Air to connect to the app

I just got the App and installed on my IPad Pro and tried the guide on how to connect but no connection. Any ideas?


Have a look at this topic:
(You can also use the search function in the upper-right corner)

It’s the iPad Pro. The new M1 chip in it won’t let you connect, there is a thought that it has something to do with the communication protocols. Have the same problem. It works with my mavic air 2, but won’t connect with my inspire 1.

I ended up buying a cheap-ish Galaxy tab A8 which seems to work ok with the inspire, much prefer an iPad though.

Thanks Mark. I have a fire tablet I can try but is nowhere near the specs of my iPad Pro.

Interesting! I know this is an old thread, but I wanted to post that I’ve been searching everywhere as to why my iPad Air will not connect anymore. It did connect at one time a few months before, but now it doesn’t. I have an old galaxy A8 tablet but I thought those did not work. Interesting that it worked for you. I will try it. Thank you very much!