How can I connect with litchi using samsung s22+ and phantom 3 pro

Hi there,

I’ll keep it brief. My specific problem is:

  • I have a new Samsung s22+ cause my old (s20) died.
  • I have litchi installed
  • I tried updating firmware on my drone using SD, the DJI GO app (which I now deleted).
  • I tried using an A6 device and an iPad. I cant use the iPad, cause its not mine. And the A6 (samsung) also didnt work
  • I can only connect using USB cause my phantom 3 pro isn’t capable of wifi connection.

I know DJI go cant connect with with my drone (only after I purchased it you find out ofcourse). But Litchi doesnt seem to work either. How so? And how can I fix this?

Greetings, Thijmen

That’s incorrect.
Download & Install the DJI GO App from the official DJI download site:

Download & Install Litchi v4.25.0, here’s the link:


Sorry I meant, my samsung s22+ cant connect to the drone using the dji go app.
I saw multiple other users (on DJI forms) talking about the same issue. I’ll test the 4.25.0 right now :slight_smile: