Gimbal turns hard to left on waypoint mission

With Mavic 2 Pro instead of pointing at POI, gimbal turns hard left and stays there.

Does not normally do that … :rofl:

As this is not the normal behavior for either the Mavic 2 Pro nor Litchi, we would need to know more details about this issue to suggest a course of action. Any problems using Go4? Has it always done this on waypoint missions or did it just start doing it? Was the drone ever in a crash? How does it behave in the various heading modes? Etc.

This is not a new issue, but Litchi claims to have fixed it. I’m still having a problem

Go4 is fine- no issues. Seems to happen on a waypoint mission with POIs. Haven’t seen it on missions with no POI. Also haven’t run anything but waypoints recently. Not sure when it might have started.

M2P is running V01.00.0770. Litchi is v4.25.0-g. Might downgrade the drone to 0670 just to see.

Here’s the email I sent to Litchi support on 9/23. I’ve gotten no response. To say I’m frustrated and aggravated would be a gross understatement.

Flying a Mavic 2 Pro
On waypoint missions with a focus on POI, the gimbal yaws several degrees to the side. Usually it’s to the left, but not always. I went out and ran some tests and got these results:

  • The error seems to occur right when the mission starts. If I recenter the gimbal right after the mission starts, it will correctly point to the POI for the rest of the run.
  • The problem only occurs in the Android app. I replicated the issue with 2 different Android devices, a Lenovo tablet and a Samsung phone, each running 4.25.0-g.
  • I ran the same mission with an iPad running iOS Litchi 2.14.2 and it worked fine, no issues.
  • The drone is running firmware version v01.00.0770

The gimbal yaw problem occurred on:
Lenovo TB-X606F running Android 10 (the latest available OS for that device)
Samsung S21 Ultra SM-G998U running Android 12
The problem did not occur on iPad Air 2 running iOS15.6.1

I created a video that shows the problem- on the left is the VLM file in Google Earth, on the right is footage from the actual flight. The POI is the set of bleachers in the center of the VLM. You can tell the the yaw of the aircraft is pointed toward the POI, but the gimbal is pointed to the left. You can barely see the bleachers on the right edge of the screen. You can see the video [here](
The Litchi mission is [here](Mission Hub - Litchi).

This is apparently a problem with the Android app. It started happening a few months ago, I’m really not sure exactly when. The last M2P firmware update was in April, 2021. This problem began long after that, so it appears to be related to an Android app update and not a firmware update.

I can imagine how frustrating this must be. I fly many waypoint missions (with POIs) using a Mavic 2 Zoom. It is at the same firmware version as yours. However, I use the IOS version of Litchi.

Your troubleshooting does point to the Android app. However, if it was a simple bug in the Android app, I would expect to be seeing many other complain about this too. But, I don’t.

The only way I know to rotate the camera yaw with respect to the aircraft is by using a horizontal finger gesture on the screen’s live camera view. So, I have to ask, is it possible that you are touching the screen with your finger and dragging to the left? I’m sure you’re probably not but I have to ask.

You can also configure either your C1 or C2 buttons to recenter the gimbal. I know that is workaround and not a solution. But it would at least give you a quick way to recenter the gimbal.

I’m sorry that I am not able to give you more help.

Not that it matters, your link to the mission does not work. I think you still have the “Private” checkbox checked.

1 Like

I just thought of another thing you can try. Experiment with this setting on and off:

Sync Gimbal Yaw with Aircraft Heading: Enables this to make the gimbal rotate simultaneously with the aircraft’s heading when you control the aircraft’s heading with the remote controller.

I don’t know under what conditions you would want this on or off but it sounds like it might affect what you are experiencing.


Thanks for your response. I’m paying attention to the finger gesture control to be certain that I’m not doing that. Have also experimented with different settings for the gimbal, have not found anything that worked.