360 Panoramas panning camera full left M2Pro

This just happened today but after the first column of shots, the camera pans full left and gets the leg of the drone in the middle of the frame. I don’t know what is causing this.

2 Likes

Check that ‘Gimbal Mode’ in ‘Aircraft Settings’ is set to ‘Yaw Follow’.

1 Like

Interesting, my m2pro did exactly the same thing yesterday. First time I’ve ever had this issue and it happened on the same day as yours. My camera would stay stuck in that left-panned position but would continue “capturing.” I’d have to cancel the capture process and fly home with the gimbal stuck in the left direction and reboot the drone to get it straight again.

Please make sure to use the latest Litchi version, there was a bug with pano in 2.12.0. It should be fixed from 2.12.1

Thanks vico, I’m on 2.12.2.

We just tested and had no issues with our m2pro and 2.12.2

Thanks for the feedback! I have tried deleting and reinstalling Litchi. Drone is working normally otherwise with all other apps. Gimbal is apparently wanting to remain pointed in the direction of my starting point. So, once the initial column is complete and the aircraft rotates, the camera remains locked in that initial direction. I have “Yaw Follow” selected.

Restarting the drone should fix this.

Restarted the drone several times, reinstalled litchi, reset all settings to default, set to yaw follow, put in a different battery, still not working properly.

Same problem here. I have two iPhones with Litchi 2.12.2 installed and have the exact same problem on both. They are a12 Pro Max and an older 6S I keep in my bag. They are both at version 15.4 but the problem was there before this recent iPhone update. The Mavic 2 Pro firmware is the latest - V01.00.0770 and I have ‘Yaw Follow’ selected.

We have identified the issue, it is due to what looks like a bug in the DJI SDK. We will try to release a fix/workaround very soon

Thank you very much.

Hi there ! I have exactly the same problem as described here. Thanks to come up with a fix for this very annoying issue.

This bug should be fixed in the latest beta versions (android build 30004121, iOS build
3041). We will try to release these versions to public release soon

Exact same issue here. Good to see @vico you guys are on top of it… excellent support and looking forward for the release…

1 Like

Should be fixed in recent public release update (4.22.0 android and 2.13.0 iOS)

Thank you. I just had a chance to test after the 2.13.0 update and the problem has been corrected.

Hello, I discovered I am having this problem with my M2P as well on Dronelink and wondering if the reported Litchi fix with 2.13 resolved this for everyone? And as I would be new to Litchi, can I now use waypoints to shoot a sequence of a dozen or so 360º panoramas? When i explored this a year and a half or so ago, this was not possible. Thanks.