Gimbal Pitch not honored

I know what’s going on here but it is difficult to describe so bear with me.

A Litchi mission using “Focus POI” does NOT cause your drone to “track” a POI (except in very specific circumstances). Instead, your drone will properly focus on a POI ONLY at the waypoints for which each POI is defined. In between the waypoints, the heading of the drone will linearly interpolate from one heading to the next as your drone traverses from one waypoint to the next.

Normally, this is sufficient to cause your drone to roughly point at your POIs with some accuracy. However, in the extreme case, where you have one waypoint far from from a POI and another waypoint really close to that POI, the heading at an intermediate position between the two waypoints, will wander off that POI. This is the case in several areas of your mission.

I know this may be difficult to follow and understand. There was a discussion about this in the Virtual Litchi Mission thread a while back. Some diagrams were created to help describe the situation. Instead of re-creating them here, I’ll point you to that discussion. Please see posts 768, 772, and 773 in this thread:


Thanks, I totally understand and I guess that all of my other missions had the POI relatively the same distance so I never noticed. I think the best solution will be to add a WP or two in between the long runs.


Sounds similar to a problem I posted about a while ago. I had the issue with a M2P. What drone/firmware were you flying?

The problem you described in that other thread has nothing to do with the issue described in this thread. What you had described (gimbal pointing hard left) is a clear malfunction with an unknown cause. The issue described here, where the camera heading seems to wander off of the POI, results from an extreme case where one of two waypoints is very close to the POI.

1 Like

Sorry for bumping this old thread but I am having a similar issue. I want to make a mission that take shots of the field below the drone (angle -90?) for it to collect images that I will send to webodm to create a hi-res map. Which gimbal option should I set to have all waypoints taking pictures right below the drone at -90?
Thank yo very much for your time!
ps: sorry, I am talking about Virtual Litchi Mission app!

For my mapping missions, I set the default gimbal pitch mode to ‘Disabled’ in the Mission settings.
At WP2, I set a waypoint action ‘Tilt Camera -90’.