Gimbal Pitch not honored

I have created Missions quite a few times and have not seen this and wonder if it is a bug in the newer versions. I created a mission with several waypoints and POIs but there are several times that the camera will point to the farthest upward angle. I checked every waypoint and it is set to Focus POI and every POI is set well below the flight level. I am going to change the gimbal angle to Interpolate and see if it fixes it, but until I can fly the mission again, I was wondering if anyone had any suggestions?

This is not the behavior that I would expect.

It may be hard for us to identify the problem without seeing your mission, so this is just a guess:

Is it possible that you have the “Above Ground” option checked and one of your POIs is higher than one of your waypoints? This might occur if the POI is positioned on top of a hill and a waypoint positioned in a valley.

If you wish to share your mission, uncheck the “Private” checkbox and post the URL here.

Here is the mission Mission Hub - Litchi
Above ground is not checked.
Thanks for looking at it.

@poporacer, I checked your mission and ran the VLM and it worked okay for me. You have a lot of gimbal angles at -4 and -6 degrees so the camera seems to be looking straight ahead until you get close to the pivot points at the corners. The camera never actually looked above the horizon for me, so the mission worked okay from what I could tell.

I cycled through your mission without finding an obvious error.

With 24 POIs and 47 waypoints, you will need to tell us what waypoint(s) demonstrate the gimbal pitch angle problem.

The first time it happened, it looks like between points 6 and 7 here is a clip. https://drive.google.com/file/d/1dQITUWhtIwc1GoU1QBMUsjBC3N_c2Xpx/view?usp=share_link

When it pointed to the sky, I manually tilted the gimbal down but you see that shortly after it went to the sky again.
@Steve_Amerson what is the VLM and maybe a link on how to use it?

I’m sure this (overcomplicated) mission went through a LOT of tweaking and changes and somehow you lost track of all the different versions you saved and tried.

I’m not convinced the mission you shared (in the hub) is the same mission in the video.
As far as i can see there’s nothing wrong with the shared mission.

@poporacer, an easy way to make sure that the mission works properly and is considered valid is to use to the VLM or Virtual Litchi Mission using the Chrome Browser Extension and Google Earth. You can test any missions beforehand, but remember that Google Earth doesn’t show the height of trees or show any changes that have happened since the last satellite photos were taken.
YouTube has videos to walk you through the process but basically you: 1.Download the VLM Chrome Browser Extension 2. Download Google Earth Pro (it’s free) 3. Go to Mission Hub and Download your file to the computer (the export option is in RED if the browser is working properly) 4. Open the file using Google Earth 5. Double Click file to open “Virtual Mission” 6. Double Click the Virtual Mission file and the mission will start.

Here is the link to more forum discussions on the VLM. Remember to tap the magnifying glass in the upper right of your screen to search any topics that interest you. I hope this helps! Search results for 'vlm' - Litchi Forum

1 Like

What is overcomplicated about it? I might have a few too many POI but on the first 2 missions, the camera was not pointing in the right direction, so I added a couple more POI to “keep it centered” but it might be because of the problem I am having. I only have 2 missions for that area, and one is completely different, so I am pretty sure the mission I shared was the one flown. I opened Litchi, loaded the mission, flew the mission and when it went wonky, quit and came home and posted the mission and video. The only way that it couldn’t have been the same mission is if my tablet somehow cached the previous mission, but I don’t see how that would be possible since I think loading the mission requires an account login and access to the servers? But I am open for any advice. I have created and flown dozens of missions with Litchi over the years and have never seen this issue so wondering if it might be a bug?

I would also say that this mission design is more complicated than it needs to be. However, no matter how complicated, your drone should be able to fly it. Having watched your video, I do see gimbal pitch angles that should not occur.

It is difficult to troubleshoot this mission because with almost every waypoint pointing to a different POI, it’s hard to follow. So, in no particular order, here are my thoughts:

  • I would start over by creating a new, much more simplified version and do another test flight.
  • While I don’t remember a specific case like yours, I have had the occasional weird occurrence during a mission. Sometimes, re-flying the mission resolves the problem.
  • I can tell that you are using a Phantom to fly. I’m wondering if interference may have caused the gimbal pitch angle anomaly. Your mission would have been loaded into the drone. However, the gimbal pitch angles (for POI missions) would have been sent in real-time and therefore, be susceptible to interference.

I’m sorry that I could not be of more help.

1 Like

How did you get the video to display the POI? Or did you have to manually enter them? And from your analysis that the camera was drifting off target was why I added some more waypoints to try to keep it focused where I wanted it. Thanks for the input.

I think I might create a new mission, like you suggested, I am not sure about interference since it happened when I was only about 200’ from the drone, I assume that the tablet is the thing that is actually sending the gimbal angles to the controller and then the controller to the drone? Or is the mission actually loaded to the controller? My tablet is old and I actually bought a new one, only to find out that it isn’t supported yet… so I have a $500 paperweight… I couldn’t find any of the older IPads so got a Gen 6 and they don’t work yet…

@Yordie How did you get the mission info super imposed onto the video?

@Yordie @wesbarris so I simplified the mission and now I don’t get the Camera pointing to the sky. I don’t know if the problem was mission related or an anomaly with my controller/tablet (since the tablet is the device that sends to gimbal angles?) My tablet seems to be very slow and I am getting a new one in the next day or two. The gimbal/drone angles still seem off. How do you edit your video to show the mission details like @Yordie did so that I could verify my settings?
Thanks

So there are at least 3 missions…

Now there’s only 1 mission…

Manually in post production.

Sorry for the confusion and thank you so much for helping. I have used Litchi for many years but not very frequently but I have not seen it act this way.
There were 2 missions for the area (now 3 since I added the Minimal version). One is the complete overflight and the other is just the entrance and then reduce to hover 10ft above the ground, so quite obvious which is the correct mission to fly. I will only be talking about the complete mission. The first iteration of the mission was done to make sure of clearance to poles trees etc. and the camera angles.
I then revised the mission to avoid the big tree (I had to abort or I would have hit it, LOL) and a couple light poles that I was a little too close to and adjusted a few camera angles.
This iteration was the one I posted with the Camera pointing to the sky and because it didn’t hit the big tree, I know it was the current mission LOL.

IC, I thought there was some way to leverage the Litchi data automatically… Thanks for sharing…

So here is my new mission Minimal Mission and my crudely edited video. Minimal Mission
At the beginning it looks fine, but at WP6, 7 and 8 they should all be focused on POI 4 which I marked with my crude red circle. But the camera is too high and way too far to the right almost like it is looking at POI 6? When it gets close to WP 8, it then focuses correctly but then on the way from WP 9 to 11, the camera now drifts to the left of the POI and the behavior is similar throughout the mission. It looks like during the long runs, the camera will drift off course for no reason. I wanted to post this minimal version before a started adding WP in between the long runs to “correct” the angle…
Any ideas?
And thanks

Try this:
Change for every waypoint:
‘Gimbal Pitch’ from ‘Focus POI’ to ‘Interpolate’.
Leave the ‘Heading’ & ‘Gimbal Pitch’ values as they are.

Remove the action at WP28, Actions are ignored in a ‘Curved Turnes’ mission, which this is.

Mission:

When you say “gimbal angle”, what do you mean? Gimbal heading (horizontal), or gimbal pitch (vertical)?

I will try that. I have found that Actions on curved missions actually do work…but only if the drone passes through the exact location. So basically, the starting and ending point since there is no curve involved…
I see that you modified the mission for me!
Thanks…

I will try it in the next day or two, weather permitting.

Both, the heading is off more than the pitch though