Getting an error code of 180 when trying to use the app

Tried to fly a mission this morning and kept receivin at error code of 180 with the indication to call DJI support. I did call DJI. They have never heard of this error code. They then had me confirm that I was able to operate my drone on the DJI Fly app, which I can. They stated that, since they have not heard of this error code and that my drone operates fine on their app, they could not support errors being received on the Litchi app. Is anyone familiar with this error code and, if so, can you share a solution?

See his thread:

1 Like

Thank you. Same exact thing. I know I just had a firmware update within the last day with my DJI drone. Since I can’t seem to find any way to contact Litchi directly, do you or someone else know if Litchi intends to make their software compatible with the new update? Or, does anyone have a way to contact them that I can’t seem to find?

Yes, I’m sure Litchi will be made to work again.

From what I understand, it is DJI’s SDK that is not compatible with DJI’s firmware release. So, it is DJI who must make an update to their SDK. Once that is done, Litchi will be able use the SDK update to provide an updated version of the Litchi software for us to use.

1 Like

The Maven Pilot app also had the same problem but has already updated to solve the issue, which suggests the SDK is available. Probably just a matter of time before all 3rd party apps are updated.

1 Like

Read today that Litchi has updated their software to function with the new Air 2 S firmware. Haven’t tried it yet.

1 Like

I am happy to report that Litchi is no longer glitchi with respect to cranking up the props on the Air 2S via iOS, so long as you go to the App Store and fetch the update (if you’re manual like me). Works now.

1 Like

Great news! Are you able to tell me what version appears on your Litchi app? I have mine set to automatically update. but I just want to be sure that it did. Thank you.

RL - Litchi version that cranks the props like it should is v2.14.3 on iOS.
I have not tried this new version in waypoint mode to see if the “Virtual Sticks”-related yaw/gimbal jerkiness is cured. But the props will crank.

Hope that helps!

Helps a lot!!! Thank you!!!

I tried again today. no go Has anyone been successful?

Alan, I want to say that I have flown with it since the fix. I use a couple other 3rd party apps and may be mistaken. I will try to go thru my flight logs and see if I can confirm it. I assume you have made certain that the firmware is up to date and have checked to make sure you have the most recent Litchi app version. Sorry I can’t be of more help.

Which platform? IOS or Android
Which drone?
What version of the app?
What version of firmware?

In reviewing my flight logs, I can’t say for sure, but I do believe, minimally, I started up the drone and confirmed the error code no longer appeared.