Error code 167 in Litchi, at the start off flight plan

“unknown error (code:167), cannot take off”

Anyone know what this code is?

Mini SE Litchi latest.

Can you post a link to the mission so that we can look at it

Must be some Dji error. I try to repeat the error, but no error now… but it doesn’t feel safe to fly with any unknown error in screen.

I have seen this error 5 times now. Mini SE, (< 6 hours flight time) current and most recent previous version of Litchi, Note 3(N9005) & Galaxy S10+. I normally use the Note 3 that only has Litchi installed

  1. I connect phone and remote,
  2. Power up remote
  3. wait for Litchi to start
  4. power up the drone
  5. This error the appears after powering up the drone.

The result is I am unable to start the motors for take off

Multiple power off and off of drone and remote rarely clears it for me (Only once so far) The only time I have had regular success clearing it is to

  1. Connect the remote to to the S10+ and start it
  2. fire up dji fly (No error is presented)
  3. exit dji fly
  4. reconnect the Note 3 & Litchi

If anyone has any idea on how to get more details or what this source of the problem is please shout.

Any ideas @litchi

I haven’t tested this but can this be about the “unbind” problem that is with us… I have old phone that can run Dji Fly-app (broken screen…), and other that I use with Litchi, but it can’t run Fly-app. Maybe (?) we must use same phone for the apps?

1 Like

Same issue, and DJI basically told me to F off cuz I’m using litchi…please advise, this sux.

This is what the DJI SDK team replied when asked about the meaning of code 167:

“ The error means “DJI CARE is used and this aircraft is replaced by a new aircraft, the motor will be locked.” This normally happens when user A loses his aircraft during a flight and he called DJI after-sales team to activate the DJI CARE service, then DJI will send him a new drone to replace the lost one. But user B accidentally find this lost aircraft and he wants to fly with it, then this aircraft’s motor will be locked. I suggest you to ask your client to contact with the DJI afer-sales team such as He should be also not able to fly it with DJI official app.”

DJI says they did not lock the motor, has it been locked by your app for your app? If so I’ll have to request a refund in Google play

Litchi does not have the ability to lock the motors, only DJI can do that.

So to me, it seems when DJI comes out with an update, it shuts down the device in litchi. When you update it in DJI fly, it works perfectly after in litchi (for me)

The annoyance is DJI fly doesn’t work with any of my phone’s/tablets except my wife’s phone, so I have to use it first then my phone with litchi.

This is getting worse… Just tested my only phone that can run DJI Fly (screen broken and not in use, only for Fly app)…

Started without data connection (flight mode, no wifi on) and Fly app gime me error, cannot fly. Error 30064.

Second test wifi on using my hotspot. Works fine. So DJI doesn’t let me use Fly app if I don’t have data connection on?

I recently got a new controller. Synced it back up to the drone. Opened Litchi and I got the 167 error.
Cannot get the dji fly app without buying a new phone.
Any other way around this issue?

I’m getting 167 momentarily when my Mini 2 connects to the controller and Litchi, then goes on to fly absolutely fine. My drone has been mine from brand new, never replaced, never had Care Refresh, etc so DJI’s response is wrong.

1 Like

If you see this error in Litchi and it persists and prevents taking off, the best thing to do is to try to take off with DJI Fly, most likely you won’t be able to and will get a similar error. Then contact DJI support to ask why.

If you see the error in Litchi and it prevents take off, but you can take off in same location using DJI Fly, then please contact with details about your setup, then we’ll forward that to the SDK team for them to look into


Hi everyone, I am new to the forum and I am a beginner pilot anyway I’ve got the same error on my tablet but I resolved.
It is a new tablet, I just installed Litchi on the tablet, connected tablet - remote and Mini Se and I’ve got the error. Then I installed DJI Fly on the tablet, I connected again tablet (with Litchi) remote and Mini Se and the error disappeared and the flight went well. So it seems that installing DJI Fly, even without using it, resolved the issue (at least for me)

Did you still get the message briefly when you launched Litchi or did it startup with no message?

I got the same error 167, i firstly try dronelink but got no success in flying with any mission, the following day i subscribed to lichi and never had a single mission executed as of this time, my phone is only samsung j7 pro and it is not compatible to dji fly app so i am trying to have any successful mission with lichi, attached is the screenshot of this error.

You need to activate your drone (not phone), and this can only be done via the DJI fly app, without being activated it wont fly with any software

Had the same error on new drone that i flew a few times. next day for the 167 error. Someone already mentioned above, but use djifly app on another phone or iPad to update the drone’s firmware. No more error for me.

Hi all, had the same error out in the field after 2 successful flights, third bailed and I was stuck. No data connection etc so no idea why it decided to error then. Got home, noticed there was an update to dji fly app, which I did, and error has now gone. Litchi still working too.
Very annoying, but these things happen