Cannot fly in "restricted area"?

Hi,
I am new to drones and to Litchi. Installed it for my Mini SE, and have a problem to fly! Just yesterday I could fly in two places using DJI Fly , today in the same places Litchi says :" Cannot fly in restricted area". I cannot switch back to DJI Fly and am frustrated. Any help?
Gregory

Why can’t you switch to DJI Fly?
You can have both DJI Fly and Litchi installed on your mobile device.
Unlock flite restriction in DJI Fly, then close DJI Fly and run Litchi (without turning off the AC & RC.

I did that and : after turning AC and RC on- in DJI Fly touching Connection Guide takes me to: Select Aircraft. In Camera View it says: "RC not connected to mobile…
Switched to Litchi…and again: “Warning: cannot takeoff in a no-fly zone.” And I cannot do anything about it. Out of the sudden I cannot take off from my backyard - I did it many times using DJI Fly.
This Litchi app needs a serious work to be useful…I will request money back from Litchi

This is your real problem.
Is your mobile device Android or iOS, and what type?
Do you use the original USB-cable?
Can you post some screenshots from the error-messages you get.

Sorry, in order to fly I had to uninstall Litchi, sent them an email for help…but I wanted to fly!
I am using Huawei P30, on Android, using the same original cables.
This is NOT a hardware issue, Litchi is still not compatible with Mini SE. For Litchi :“Warning: cannot takeoff in a no-fly zone.” For DJI Fly it is a message : “Aircraft in the area, fly with caution”, Take off permitted. For me it looks like Litchi is more strict than Canadian Aviation Regulation.

If you require an unlock license to fly, this must be loaded into the drone using DJI Fly. Litchi does not perform any unlocking. It is always done using the DJI app (Go, Go 4, Fly, …). Litchi is not more strict or less strict than the DJI app. The “Fly Safe” database is the same no matter which app is used to fly the drone.

According to their documentation, Litchi is compatible with the Mini SE. I have been using Litchi for years and it is very useful. One of its most useful features is the ability to plan waypoint missions on your computer then fly them with your drone.

1 Like

You can’t just switch between the Fly app and Litchi on Android, only one can run at the same time. You need to force close whichever one you’ve closed before launching the other.

Just close one normally and open the other, no need to force close

Not from my experience, strange behaviour in the 2nd app. Running Android 11.

There seems to be some confusion between “Force Stop” and “Force Close”.

On Android:
You “Force Stop” an App by opening Settings, then Apps, then choosing the App you want to “Force Stop” and clicking on the ‘Force Stop’ screenbutton in the picture below.
This is indeed NOT neccessary.

It is however neccessary to completely Close (Force Close or Deactivate) one App before opening the next App, like shown in the picture below:

It’s recommended to do the same on iOS (the procedure differs).

On android I just double click the back arrow to exit the app and them open the other app, but it’s rare to have to open DJI fly

I installed again Litchi to see if your suggestions work. As you see from a screenshot Litchi says :“warning. cannot fly in a no-fly zone”. So I turned Litchi off and turned on Dji Fly…
( I will post another screenshot in the next reply since this forum doesn’t
allow me to post two pics…(?)
DJI Fly now cannot see the RC. ( what a mess!!)
So for me to fly I have to uninstall Litchi !! And DJI Fly will let me take off.
As I said earlier Litchi is NOT compatible with Mini SE…It sucks, I paid for the useless garbage.

The reason the RC is not connected to mobile device is you did NOT Force Close (deactivate) Litchi before you strarted DJI Fly.
The second screenshot in my previous reply:
“It is however neccessary to completely Close (Force Close or Deactivate) one App before opening the next App, like shown in the picture below:”

I did that just now…even if I force closed Litchi - as per your instruction - DJI Fly didn’t see RC. I force closed DJI Fly and still Litchi didn’t allow me to fly.
THE ONLY option was to uninstall Litchi and then DJI fly gave me permission to take off. Btw. next time please say something you know for sure.
I saw on YouTube video from Australia that Litchi worked with DJI Mini SE…well… maybe if I moved to Canadian Prairies…Litchi would give me permission to fly.
As for now LITCHI IS NOT compatible with DJI Mini SE

Btw. next time please say something you know for sure.

Repair your android phone. It’s not Litchi’s fault that you don’t know how to use a phone.

So what exactly should I repair?? There is nothing in Litchi app to instruct Android uses to correct first…(my P30 runs on ver.10)
It’s simpler to call names than admit wrong…

Try another phone before saying that the problems are in litchi and mini se

Hi Gregory,

I can tell you are frustrated by your experience with Litchi, DJI Fly, and your Mini SE. Unfortunately, we haven’t been able to tell what you are doing wrong from your description so far. I can assure you that the process described by @TriBar works as many are going through those exact steps successfully.

I am an IOS user. In IOS, the process is similar in that you should “force close” one app before using another. The details on how you do that is different though. I have been prevented from flying using Litchi because of an authorization zone. I had to close Litchi and use DJI’s app to unlock the zone, then go back to Litchi.

I know the process works. Many people do it. Maybe you will need to provide more details on exactly what you are doing to help us pinpoint the issue. There are a lot of experienced people here on this forum who are willing to help. Showing them respect will go a long way to solving your issue.