Application not licenced

Phantom 3 Adv Samsung T710 Android Litchi ver.4.23.0-g
When I start Litchi I get a message: “Application not licenced.Can not validate licence… Check network.”
It has work ealier for years and now it will not start.

I’m guessing that your Android version is just out of date. Your version came out in April 2022 and a new version (4.24.0) cane out in May 2022.
I would suggest updating the app, then ‘Check and Sync License’
Let us know what happens.

How do I update the app. Do I have to reinstall the app. Can you please tell me. do I have to uninstall it and pay again?

Update it like you would any other Android app. It should show up in your Google Play Store. No need to pay for it again.

U have to be logged in to your Litchi account in app I believe :pray:


Hej Mats
Talar du svenska?

1 Like

Jajamänsan! Mitt modersmål typ… :slightly_smiling_face:

I had same issue recently in mexico.
“couldn’t validate license”
I was in middle of ocean so I couldn’t fly.
It worked fine when I got internet

OK Mats,
jag har försökt uppdateraLitchi på Google Play Store men sidan påstår att jag inte har den Samsungpaddan jag har. Dessutom är den klickbara rutan “blekad” så jag kommer ingen vart

1 Like

Ojdå? Tja till och börja med måste du vara inloggad på Google Play Store med samma email som användes när du köpte appen. Men det är möjligt också att du försöker installera Litchi på en tablet som inte är supportad av Litchi i ett tekniskt avseende.

Jodå, jag har flugit med Litchi på den här Samsung-paddan i ett par år och plötsligt fick jag meddelandet
“couldn`t validate licence” när jag skulle ladda Litchi för att flyga.

Ja då hänger det helt enkelt ihop med som jag skrev i mitt första engelska svar, du måste numera logga in i Litchi appen på ditt konto hos Litchi. I appen hittar du en ikon som sitter i översta vänstra hörnet. Klickar du där kommer en ny rad fram varav det mest högra alternativet är din inloggning till Litchi kontot där dina wp missions lagras. Simsalabim broder :pray:

Tokigt nog kan jag inte prova din lösning eftersom jag, i min iver att lösa problemet, avinstallerade Litchi från paddan för att prova ominstallera det. Nu svarar Litchi-appen att jag inte har paddan,som jag fortfarande har!! På mobilen har jag fortfarande ett fungerande Litchi och på datorn är jag inloggad på Litchi-sidan och kan som tidigare skapa rutter och även se mina sparade dito. Verkar som jag hamnat i en återvändsgränd :frowning_face:

At the time you had this message you did NOT have internet access (…Check network).
That’s all.

Most likely your phone and tablet use 2 different google accounts.

Litchi should work just fine on the SM-T710 (Samsung Galaxy TAB S2)
Try version 4.25.0
You can find the download link in vico’s comment here:

After installation make sure you have:
-Internet connection
-after starting litchi, log in with the correct Litchi-account.
-use the correct google account


Do I need to have internet signal for Litchi to work now? For several months, I’ve been unable to fly with Litchi, so looking for alternatives. I’ve been flying for years with Litchi; almost never in places with cell signal. Has something changed?

I can’t even start the app recently. After driving 4 hours to a location and 4 hours back, I now keep Kittyhawk and DJI GO installed since Litchi is not reliable for me and currently when I try to open the app, I get a message telling me that my license is not valid. I can either “exit” or “buy now.” “Exit” exits the program. 'Buy now" takes me to a Google Play page where options are to “uninstall” or “open.” I’ve not tried “uninstall,” but I assume it uninstalls the program. “Open” takes me be back to the message that my app is not licensed, with the “buy now” or exit buttons again, and is a continuos loop (bug) in Litchi.

As of version 4.23.0 (april 2022)
-Litchi will now prompt you to login or register a Litchi account. We recommend doing so in order to make sure your license is synced with Litchi’s servers for future updates.

Before you leave your home, connect your device (phone) to the internet, open litchi, go to General settings and tap on ‘Check and Sync License’.
Now litchi will work as usual (for several days/weeks) without internet connection.


That’s what I was looking for. Didn’t know I had to sync anything since it worked fine at first.
Of course when I wanted to fly I didn’t have internet.
Thanks for clearing that up

Normally, you don’t have to use that “Check and sync license” option. However, there may be a period of time (weeks or months) after which it is required. When it is required, you obviously need a network connection for it to work.

1 Like