Air2S and does not change to Next POI

Hi everyone, I am relatively new to Litchi. I have an Air2s and RC Pro. I recently created a waypoint mission with several POIs. The camera was to change from POI1 to the next POI at each waypoint.
The total mission was about 4 minutes and about 7 waypoints at 50mtr altitude.
Each of 5 POI’s have an altitude of 5mtrs.
The aircraft followed the flight path, but did not turn to point in the direction of the second POI and subsequent POI’s. It stayed pointing to POI 1 for the whole mission.
The mission was created in Litchi Hub and saved. Also map was downloaded and uploaded to the RC prior to leaving home.
Has anyone experienced this and have a solution or possible solution on where I might have gone wrong…

In the mission hub or in the app assign each POI to the relevant WP.

Hi TriBar, Yes, I have assigned each POI to waypoint in the mission Hub. So I am still baffled as to why this did not work.
I will double check it in the mission Hub.

It sounds like you have done everything correctly so I’m wondering about this statement. Are you saying that as the mission progressed and the drone traveled from one waypoint to the next, the drone always yawed to keep its camera pointing toward POI #1? If so, this suggests that all waypoints were configured to point at POI #1.

Perhaps you need to make your mission public and share the URL here so that we can take a look.

Hi Wesbarris,
The mission was created to fly over a lake, several hundred kilometers from where I live.
It is not practical for me to return there easily.
For this reason I have deleted the mission from the mission hub, but double checked it before I deleted it. I could not find any errors.
I still have similar missions on the mission hub over that same lake.
However, I am not aware how too make them public. Perhaps you could advise me.
Regards Brad

This will explain how to share a mission.

1 Like

Thanks to all that have commented.
It has helped.

Here is a mission similar to the one I had trouble with. Mission Hub - Litchi

As I said I am a beginner at litchi. I think I will create a small mission close to home and try again.

It is probably user error.

In that mission “Mission Setting” “Heading Mode” is set to “Manual (UC)”, meaning rotating/yawing will ONLY react to user/stick input.

As a beginner you should read the Online User Guide, it tells you what “heading Mode” to use, and so much more.


Hi All, TriBar, I knew it would be something simple. Thanks so much, I will definitely take your advice and read the online user guide.
Kind Regards

1 Like