After using Spiral Mission Creator heading doesn't change in google earth pro

I’ve used the spiral mission creator several times in the past and have had no issues. For some reason, when previewing a mission that I created a spiral for, selecting interpolated gimbal pitch, the heading in google earth pro stays stuck at the heading angle that was set entering the spiral. Virtual litchi mission settings shows the correct heading angles for each waypoint in the spiral but, when previewing in google earth pro, the heading stays at the point it entered the spiral at and stays stuck at that heading angle all the way through the entire mission. It never changes. I can load previous saved missions and preview them in google earth pro and the heading angle changes like it should for each waypoint. If I create the spiral, selecting POI, and then preview it with google earth pro, then the heading angles change correctly for each waypoint that was determined for the POI. If I then change the gimbal pitch settings, for each waypoint to interpolate, in virtual litchi mission, the heading no longer follows the heading angles and stays stuck at the previous heading once it enters the spiral.

I’ve uninstalled and re-installed virtual litchi mission v2.8.2 (and several older versions) with no change. Setting gimbal pitch to interpolate won’t follow the heading angles that are set for each waypoint. I have litchi set to Waypoint Defined “Custom” the entire time. When setting to POI for gimble pitch and then preview the mission, then the heading angles are followed as set by litchi for the POI.

This started happening just recently after I hadn’t created any new missions for a few months. Anyone else experienced this or have any ideas?

This suggests that your “Heading Mode” is set to “Initial(ID)”. I know that you said you have it set to “Custom(WD)” but your description of the issue points to the heading mode.

Would you describe what you mean by this? Are you selecting this in the “Settings” dialog? If so, that will have no effect on a mission already created. Are you selecting this for one of the waypoints? While that may change the configuration of the mission, it will have no effect on the heading. Are you selecting all waypoints and changing all of them to have interpolated pitch angles? That to will change the mission configuration but should have no effect on the heading.

Please clarify where/how you are selecting “POI”. Is this in the spiral creator or in Litchi’s Mission Hub?

I’ve just created a spiral mission and previewed it in Google Earth and everything worked as expected. You will need to clarify exactly where and how you are changing the gimbal pitch.


I always use Custom(WD) for all my missions. I like to be able to control the heading angle.I’ve de-selected and re-selected Custom(WD) for the heading mode in litchi and it makes no difference in regards to previewing the mission in google earth pro. Heading angle won’t change to the headings for each waypoint created by spiral maker when previewing the missions I now try to create.

The heading angles are created in spiral maker and downloaded as a .csv file to import into litchi. The heading angles are all correct in each of the waypoint settings in virtual litchi mission. Gimble settings, in the portion of the mission created by spiral maker, seem to also be ignored when set to interpolated and previewed through google earth pro.

For some reason when POI is selected in waypoint settings, litchi settings, and spiral maker settings, the heading angle is followed correctly when previewing the mission in google earth pro. Once I select interpolated in spiral maker, litchi settings and the individual waypoint settings, neither the heading angles or the gimble angles are followed once the mission enters the spiral maker created waypoints, when previewing the mission in google earth pro.

Did you select interpolated in spiral maker, litchi settings and the individual waypoint settings? Or did you just use POI for all?

I tried both POI and Interpolated in the Spiral Mission Maker. After importing into VLM and then Google Earth Pro, all tests I performed behaved as expected.

When selecting “POI” or “Interpolated” in Spiral Mission Maker and importing into Litchi, the setting of “Default Gimbal Pitch Mode” in Litchi’s Settings dialog will have no effect. This is because the gimbal mode is part of the CSV data that is imported. The “Default Gimbal Pitch Mode” is only for new waypoints created inside Litchi. Switching between “Focus POI” and “Interpolate” will also have no effect because the interpolated gimbal pitch angle is also pre-computed and loaded from the CSV file.

Because I cannot duplicate what you describe would you be willing to share a mission so that I could open it using VLM and preview the flight with Google Earth Pro? Make sure you share one that exhibits this incorrect behavior. To share a mission, uncheck the “Private” checkbox in the “Open” dialog, then copy and paste the URL here.

1 Like

Perhaps it’s related to the VLM version.
The latest version is v2.8.2.

If you would rather not share your mission publicly, you may send me a PM with the URL so that I can troubleshoot it.

There is no URL that shows up. Where there should be a url there is nothing.

This is a screenshot. There is no address bar.

The URL (link) is displayed in the address bar of your browser.

1 Like

If you are using VLM you will have to switch to running the Mission Hub in a browser to see the address bar.

Same result. There is no URL displayed in the address bar of the browser. Is it possible to mission file to a file sharing site? If so, do you have one I could upload the mission file to?

What about this? Is this the correct URL?

@SL1 ,
Yes, that does share a spiral mission

I just saved the mission you shared in my Litchi account and then used VLM (v2.8.2) to preview it and it previewed as expected with the heading view always pointing to the POI in the center. I don’t know why it is not working for you. Try resetting your VLM settings by holding the “Shift key” down while opening VLM.

Here is a snapshot of what your mission preview looks like from my system:

I reset VLM but no change. That confirms it’s only on my end then and I have no idea how to fix the issue. I’ve uninstalled and reinstalled both VLM and GEP and nothing changes.

Here are two screenshots showing how it looks on my end. It’s not following the heading angles. The heading angle is completely wrong!

Your subject says “After using Spiral Mission Creator…”. Does the Google Earth heading problem only occur after using Spiral Mission Creator or does it happen on any POI mission?

If I create the spiral as POI, instead of selecting Interpolated, in spiral maker, and then import it into VLM, it will follow the correct heading angles when previewed in GEP. All my previously created missions, POI or Interpolated, work fine when previewed in GEP. Seems anything that I newly create will not preview with the correct heading angles, unless it’s strictly created as a POI mission.

Thanks. So this has nothing to do with “Spiral Mission Creator”. You are saying that any mission using interpolated headings no longer preview properly in Google Earth Pro. Correct?

From what I’ve been able to try and create so far, yes, correct.