Worst purchase I ever made

Worst purchase ever! Wanted to try out follow me and waypoints with a Mavic Mini 2.

Hit Follow to change modes. The drone takes off into a tree and crashes. It all happened so quick. Can’t take off because drone is unstable/not upright. Branches are too high can’t even reach the lowest one. Is screenshot accurate? If so my drone is over 23 feet high. I can’t see where it is. It has 58% battery left.

To make matters worse Chime Visa is having issues right now so I can’t even purchase anything to help. I was able to purchase one 10 foot piece but that’s not long enough to reach anything.

There is a warning during takeoff that you need to choose a location and altitude so as not to crash anywhere. It’s also written in the user manual.

1 Like

There is no warning as when I took off I was in normal mode flying around as I normally would. I then pressed to change into Follow. I saw a YouTube video where a guy drew a box or something. I saw nothing about it… drone immediately went up and backwards into tree.

I also have no manual… I bought app on Google Play installed it and that’s it. That’s why I started to watch a YouTube video it did not mention anything in the instructions to download a manual or that there was one.


Follow causes the aircraft to follow the movements of a subject.
The subject is usually the mobile device that is connected to the drone but it can also follow a pin on a map or a second mobile device running the Litchi Magic Leash app (Android only).

Warning It is advisable to only use the Follow feature in wide open areas.


How did you get to the litchi forum and miss the user manual on the site


Sorry about your drone. I’m sure that is frustrating. However, I don’t think the issue is with the purchasing of Litchi. Instead, it is likely that your “Follow Settings” caused it to fly into a tree.

“Follow Mode” is used to make the drone follow the GPS signal of your mobile device. When you go into follow mode, the drone should not have taken off as you said. Once in follow mode, you would open the “Follow Settings” dialog and set them as you wish. After they have been set, then you can press the “Follow” button to cause the drone to follow your GPS coordinates.

The box you mentioned seeing on YouTube is from Litchi’s “Track Mode” which is something different.

The “User Guide” button is right next to the “Forum” button that you used to access this forum. I would suggest you read up on using the “Follow Mode” before attempting to use it.


Impossible !

It takes at least 4 clicks for Follow to start:

  1. Click the Upper-Left corner to choose Modes
  2. Click on Folow
  3. Click the Follow Settings Button
  4. Click Start

Yes I did that and it flew in a tree. I saw no way to select what I wanted it to follow.

Because I didn’t buy the app here. I bought it on Google Play. I only came here after the problem.

The mini2 have no obstacle avoidance, use all autonomous mode in a really open and wide area, the app can’t see or stop if there are something in the way. If you have a tree near enougth that you didn’t have time to stop the mode, you are NOT in a open area.


So that’s what must have happened. I went into settings and hit start and that caused the drone to fly 10 m high and 10 m away… the problem for me is 10 m high and 10 m away from what I never selected any item to focus on or follow. By the way if you notice I never said the app was a piece of garbage or anything I just said for me it was the worst purchase I ever made.

“Follow Mode” is designed to follow the GPS coordinates of your mobile device. It is not something that you have to select. Instead, you select the orientation and distance from your mobile device that you wish your drone to be. You must have had your settings configured to position your drone towards the tree that it flew into.

The implication of this thread’s subject is that there is something wrong with Litchi. Have you heard of the saying about a workman who blames his tools? A better title for this thread would be something like “What did I do wrong that caused my drone to fly into a tree?”.


Ok, so you got the app from the play store, didn’t read any manuals or how to use the app and then decided to just go for it and while doing so pressed something you didn’t know how it fully worked and crashed into a tree? I have very limited experience flying but before I try to do anything and crash my ( very expensive ) drone I try to read and learn the features.


And then he immediately went to the forum and wrote that he made a bad purchase of the application. )

1 Like

Even if you hadn’t found the help in the app, loads of videos on you tube that explain all the various modes and how to use them

Sorry for your loss.

However, if this is the worst purchase you’ve ever made may I suggest you are living a charmed life.

1 Like

Litchi is by a wide margin the most versatile and intuitive waypoint planning software package that I have ever tried and purchased. Nothing out there even comes close, and yes, I did acquire other similar but patently inferior products that I wound up never using at all.

To the gentleman who uttered that most shocking and sacrilegious denouncement of Litchi, I am compelled to challenge you to face your destiny by way of an honorable duel in which we will both deploy matching flintlock pistols at high noon behind the junkyard over on 6th street. May the best man win.

1 Like

It will follow the remote. There is no box to draw in follow mode. A little study before use can go a long ways. Don’t blame the app because you did not acheive instant gratification and had horrible results. The app works great. Most crashes are from pilot error but hey blame the app if you feel better.


Well. So far its the best buy this year to date. Have lot of great shooting after few weeks. And am 56 and total new to drone.
Nothing wrong with litchi. Follow modes sucks, but thats the drone. Buy better drone

Possibly the best app purchase I have made for Android, Drone Pilot Canada is another excellent spend.

Its tricky to get follow mode to do what you want at first, but it does work well. You really need to be way out in the open until you fully understand and experience its behaviour.

Worst purchase I ever made was some bad blotter in the 70s! lol