When I Connect USB cable with Litchi on IOS iPhone, the DJI Fly Opens Up & Takes Over

I have closed DJI Fly app and all others before connecting Mini 2 drone, RC, IOS iPhone 12 ,USB Cable and then open Litchi app… But DJI Fly opens up shows and takes control…so both Litchi & Fly are open simultaneously. I read another thread today that said to make sure, DJI FLY is not set as the DEFAULT app…that the ‘Once’ setting is selected or something to that effect. But I have searched for this thread and can’t find it before opening this topic.

I’m Following These Instruction for IOS from Help Guide:
iOS

  1. Make sure no DJI-based apps (including DJI Fly, DJI Go and other third party apps) are running in the background. If there are any, close them. (I made sure DJI Fly was Closed)
  2. Start your drone and remote controller if you are using one, and let them initialize for a few seconds
  3. Connect the remote controller to the mobile device using a cable. For Wi-Fi based drones (Phantom 3 Standard/4K or Spark), connect to the Wi-Fi network of the drone instead
  4. Start Litchi. (No reference to Removing Defaults of any kind…but wonder if this is the issue.)

I have scoured the IOS FLY app settings and can find no switch remotely connected to making DJI FLY the default app so I can remove it. I just bought Litchi today and this issue popped up right away. I can barely spell Litchi…

Can someone give me the menu path to remove the DJI Fly as the default flight app if this is, in fact, the problem?

Aside: Manual says that when opening Litchi for the 1st time a ‘registration’ process begins. This never happened. But I was able to login successfully.

For the registration, you will only see anything if there is an error.

For DJI Fly auto launching in iOS, unfortunately we don’t believe there is a way to disable that so you have to kill DJI Fly every time you want to use Litchi

1 Like

On my iPad mini 4 this does not happen.
I had Litchi installed long before the Fly app even existed.
In other words, Litchi was installed first.

So you could try uninstalling both Litchi and Fly, then install Litchi again and run it with everything connected and then install Fly again.

1 Like

Hi guys, I have an identical problem, I connect the IOS system cell phone to the drone via RC and take off, open the mission, but when I press play, these two messages appear.
Can someone help me?

due to a bug inthe DJI iOS SDK FOR AIR 2S, IT IS required to restat a new autonomus flight. We will update litchi with a fix for this issue as soon as DJI releases an updated SKD

In APAS mode the forbid side fly sideways If you need to fly sideways, please turn off forbid side fly swtch

Hi TriBar,

I have an iPad Mini 5. I also had Litchi installed long before DJI Fly. However, when I start my Air 2s, DJI Fly also starts (even if I already have Litchi running). To the best of my knowledge, there is no such thing as a “default app” in IOS, so no way to change that behavior. I just have to force-close DJI Fly after it starts up.

Hi Carlos,

The first message is just what is says. There is a bug in DJI’s SDK that requires you to temporarily stop and start Litchi if you want to fly subsequent waypoint missions. DJI needs to provide a fix for this.

I have not see the seconds message you mention.

1 Like