Waypoints - Lost of control

Tonight I flew two missions with my mini 2 using Litchi waypoints, the first one went very well, but at the end of the second mission, the drone left and I couldn’t control it anymore. as it was getting to the end of the battery, it landed in the center of the lake…

I am sorry to hear that. Why could you not regain control? There are several ways to regain control at any time during a mission:

Regaining Control

Whenever the drone flies autonomously, you can regain control instantly at any time using the remote controller’s flight mode switch.

  • For newer drone models (Mini 2, Air, Mavic, Phantom, Spark and Inspire series), toggle the flight mode switch from Normal/P to Sport mode in order to regain control. You may switch back to Normal/P mode afterwards.

Alternatively, you can use the red stop button in the left button bar to stop an autonomous flight and regain control.

The app might have lagged, but there is always the emergency stop / RTH button that will stop any action no matter the app or situation. That would have worked.

The analysis of the accident shows that several factors led to the loss of the mini 2:

  • It was night time.

  • The pilot was on his first flight using the “litchi waypoints” software and had just successfully completed a first simple mission in waypoint mode.

  • The second mission had been copied from the Lithci Mission pc software, and was the mission of another pilot.

  • This new second mission had been moved one kilometer upstream on the lake.

  • When the drone finished the second mission, it obviously took the direction (rth) of the original mission of the other pilot. This point was 1 km away from the new location where it should have returned.

  • He had started the mission with a battery that had ca 60% capacity left. This put the pilot under time pressure, a 5’ reserve would have certainly allowed the pilot to regain control of his drone.

  • The pilot had about 20 hours of flight experience with the drone, but had never used the rth button on the remote control, always using the rth button on the dji fly software when needed. He didn’t saw the rth button on the litchi app.

  • The night, prevented to distinguish precisely on the control screen the exact place where the drone was traveling.

  • The pilot, under pressure, did not think of leaving the camera mode to switch to map mode, which would have allowed him to see that the aircraft was 100 m next to him over the water.

  • Another drone was flying in the vicinity and in the night, the pilot thought he recognized his drone and based his actions on the wrong drone, which did not react to the commands and for good reason!

The mistake:

  • It was a first experience of flight in “litchi waypoints” mode, he should have chosen a less dangerous site with daylight.
2 Likes

Sorry to hear that. Have you bought the DJI Care Refresh program?
Even though it’s gray area DJI has stated to several people they should be covered even when using 3rd party app.

1 Like

Thank you for advice!

Wot no boat to hand?

That is not what DJI Support NL told me when I asked the specific question. Their reply is:

Regarding your inquiry, we understand that you would like to confirm information about DJI Care Refresh service plan. To address your concern, kindly be informed that LITCHI is a third-party app and the third-party app cannot be used. Our site have not performed official tests and cannot guarantee its stability. Please be informed to use the corresponding official DJI app.
Upon checking on the DJI Care Refresh service plan exclusions, any damage caused by using your DJI product together with a non-DJI product or third-party accessory/software that is not authorized by DJI.

1 Like

But many people asked about this and DJI answered that they do cover it, but only if it was user error, not litchi app error. Check the video about it on Gavinhr’s youtube channel, he made a video about this.

Tell you what, I’ll stick with what DJI tells me about DJI Apps or not! I value my Mini2 and cannot afford to lose it!

2 Likes

Yesterday I experienced the same, after the first mission I flew it again because I forgot to enable recording. Suddenly it stopped and was uncontrollable. Even the emergency-stop-button didn’t help. Finally I changed from waypoint to fpv-mode and this resulted in restoring control. Some days before the same behaviour but in this case I was able to restore control after some minutes by pushing the stop-button. My drone is a Mavic Pro and my missions were created by learning the waypoints. So also my case states that probably always the second mission of one flight is failing, something that Litchi should take care about before more drones get damaged or even worse, personal injuries.

Remark: flying two consecutive waypoint-missions with the DJI4-app does not expose this issue.

In the meantime I have examined the log’s of the “issue-flight” but could only find the behaviour I have seen being reflected. What I was not able to find is the operation of the emergency-button. Does anyone know if it is supposed to be part of the log’s?

Post the logs here, that will help to find the reason why it decided to misbehave.

If you long press the button it should show up as mode changed to go home

Thanks guys for responding! Martin, I’m sorry but I was talking about the PAUSE-button, not the RTH-button.
Yaroslav, how would you like the logs being posted? As part of the message or is there another preferred method? By using the “upload”-icon I can only select media, right?

They are one and the same button (at least on the mini2 controller), single press to pause flight, press and hold to initiate RTH

1 Like

This is typical of what can happen when the optical obstacle avoidance sensors get fooled by sun rays.
When you fly the same mission multiple times, just turn off obstacle avoidance.

1 Like

I will give it a try. Thanks!

TriBar, I’m sorry but to me it doesn’t make sense because the logs don’t reflect any obstacles in this phase of the flight. I also don’t understand why it’s always (as least in my case) the second waypoint-mission of a flight having this problem. Both missions were exactly the same, I had to fly it again because I forgot to start the camera. During a flight some days earlier there was no camera-recording at all, the flight was just for practicing purposes but the same problem. To me this still sounds like there is a problem with the Litchi-app.

Is there anyone with a Mavic Pro, tried to fly two consecutive waypoint missions in a single flight, experiencing the same as I did?