Waypoint mission problem

Hello all!

New user here…

I have prepared several waypoint missions in the hub, but when I try to execute them, after I select from which waypoint to start, it says the mission was aborted because the flight mode changed. (DJI Mini2)

Any ideas?
Thank you.

Welcome @Lambis,

Two things come to mind:

  1. Make sure your controller is in ‘N’ mode
  2. Make sure the app displays ‘Waypoint’ (upper left corner)

Good luck

Have a look at vico’s reply (#6) in this thread:

Thanks for the answers.

I was near a no fly zone but not inside. The first waypoint where the error happened was about 45 meters from the zone. The closest waypoint to the no fly zone was 11 m. away from the NFZ.

Do you think that is the reason?

I also received that error using Litchi WP plan, Track mode and follow with DJI Mini 2, FW all up to date.

  1. Taking a hint from Sam_G, I went to a uncontrolled area - No problem Litchi WP.
  2. Went to a 200ft ceiling control area - no problem. No issues with DJI FLY either
  3. Came back to original location (100 ft limit, 0.25 miles from no-fly zone) and flight aborted. Yet DJI Fly has no issues. Obtained LAANCE authorization, started DJI FLY process in drone, exited / force stopped DJI FLY, engaged Litchi WP - NO GO. Tried all kinds of sequences to get LItchi to acknowledge LAANCE Auth, but to no avail.

HOW DOES LITCHI work with the fly zones? Seems minimal Info available.

Thanks for any further insight!

LAANCE authorization has nothing to do with whether or not you can fly with Litchi (or DJI Fly). However, if the area you wish to fly is geofenced, the authorization zone must be unlocked using DJI Fly. Unless that is done, Litchi will simply not let you fly a mission that is in or tries to enter a geofenced area.

Thanks for the direction to geo zones.
In reviewing GEO zone: Yes my position is ~100 feet within the restricted GEO zone.
I open the dji fly app, then accept the restrictions, engage the drone - hover, close of the dji fly app, and engage Litchi WP. But this is where it indicates mission error “flight mode changed”. (flight plan does move from restricted to non-restricted space)
Resetting the drone, re-enabling DJI fly App, accepting the restrictions, DJI flys equivalent WP manually just fine.???
Any ideas as to why the dji fly acceptance to the restrictions doesn’t allow litchi to allow flight plan but creates error??
Interesting from cold start, then engaging Litchi only, Litchi knows it is inside GEO zone and prohibits flight - How does litchi know where it is? Smart AI?
The issue is that surveillance of POIs by WPs are in partial GEO zones that are prohibited to operate in Litchi app. Yet DJI FLY has no issues.

I have found another post by someone with an Air 2s that received the same error during a waypoint mission. He found that by turning “Collision Avoidance(APAS)” off, allowed him to successfully fly the mission. You have a Mini 2. I don’t know if this option is available to you. If it is, turn it off and give it a try.

All DJI drones have a GPS receiver. The “FlySafe” database is also loaded into the drone. That is how it “knows” were it is and whether or not it is in or near a GeoZone.

I have flown a waypoint mission near and in a DJI Blue Authorization Zone. Prior to engaging the mission, I used Litchi to fly toward the first waypoint which was inside the Blue Authorization Zone. When the drone reached the edge of the zone it was like I hit an invisible wall in the sky. I could navigate along the edge of the zone but not fly into it. Litchi provided no error messages when manually flying. At the time, I did not know I was close to an Authorization Zone. I landed, stopped Litchi and opened DJI Go4. Upon stating the motors, I received the Authorization Zone message. I self-authorized and could start the motors using DJI Go4. I stopped Go4 and re-started Litchi. From that point on I could fly my mission inside the Geo-Fenced area.

1 Like

Got it! Thanks for further illumination!!
And yes, as indicated in previous dialog, DJI Fly app was given permission, Drone was able to navigate via DJI until the drone edged the actual NO FLY GEO zone by our airport. Then landed, closed DJI, and Activated Litchi, but Litchi had the error: “flight mode changed”.
So it seems that Litchi, with Android, doesn’t get the “permission” token to fly in my case.
Maybe next rev for Litchi will enable this feature (or maybe it is the DJI Fly app that needs updating?). However, at this point it is somewhat frustrating as POIs for a project are just within the edge of the GEO zone.
I’ll need to experiment to see what the position resolution / precision is wrt GEO zone edges are for the Mini2 GPS, and the Fly safe data base - which one has the largest error - would love to see the comparison math!..

Try turning off the “APAS” option that I mentioned above. There are no permissions that need to be enabled in Litchi. This is all done in the drone.

I don’t think there is anything that Litchi needs to enable. It appears that you have have done the appropriate steps to unlock the geofenced zone using DJI Fly. Try the “APAS” option.

Maybe I’m missing something, but I found no option for “APAS” disabel for DJI mini 2 with DJI Flyapp.

Thanks for the encouragement.

You won’t as mini 2 doesn’t have the sensors required

My mission worked once I deleted the waypoints within 20m from the edge of the no fly zone. It might differ in your location so maybe you should experiment. I could fly with Litchi up to the edge but only manually.

Seems to be true! Thanks!

UPDATE to Litchi NOT able to fly in enhanced warning zone as previously stated.

Since some of the comments indicated it should work, I finally went back re-try the Litchi waypoint mission in enhanced warning zone.

Using DJI fly app, requested unlock, received the code and entered it. DJI could fly now.
Closed DJI fly app.
Activated Litchi waypoint mission in the enhanced warning zone AND IT’s a GO!! No issues!
Not sure of what I was doing wrong before, BUT today it worked flawlessly!
Issue resolved (until a next time).
Thanks for the dialog on this!!

1 Like