Using a DEM - I cannot get this to work

I cannot get a DEM to work in the Mission Hub.

The DEM is from the UK Government - a standard GeoTIFF that I convert to WGS 84 (web mercator, though I’ve tried several other varients, too) in ArcGIS Pro, before exporting as an ESRI ASCII Grid file (.asc).

The file uploads far too quickly to the website (at my connection speed it should take about a minute, and it takes less than 10 seconds) and the end result is always the same. The map is replaced with a uniform grey, and the website says no DEM is available.

I can display the DEM in both ArcGIS and QGIS - it isn’t corrupted.

The post ‘Importing DEM into a flight plan’ doesn’t provide a solution.

I’ve spent 2 hours looking for a solution online but cannot find one. I’ve complied with the (limited) guidance provided on the Litchi website.

Could someone help fix this?


I’ve never worked with DEM files but I would like to give this a try. Is there a place where GeoTIFF (or .asc) files can be downloaded?

DEMs are often GeoTIFF and where you can download them from depends on where you are in the world.

In the UK, DEFRA provides a good online portal, though coverage is patchy.

There is worldwide data from an old NASA Space Shuttle mission, though relatively low resolution.

You can also make your own using Open Drone Map and Docker - though this does take a while and will hammer your computer. (You can use cloud processing, though, for a small fee).

Unfortunately, until we hear from someone at Litchi, none of them seem to work with Mission Hub/Litchi. :frowning:

Please follow this process to convert the file in the format the hub will understand:

On Windows, assuming you want to convert a file called ‘in.asc’ or ‘in.tif’:

  1. Follow the quick start steps to install OSGeo4W at OSGeo4W
  2. once installed, launch “OSGeo4W Shell” (you can search for it in the windows search bar), this will open a command line window
  3. ensure that the input data file is in the command line’s working directory
  4. optional step if you have a tif file, convert it to asc with this command: gdal_translate -of AAIGrid in.tif in.asc
  5. type the following command: gdalwarp -s_srs EPSG:27700 -t_srs EPSG:4326 -of vrt in.asc out.vrt
  6. then type the following command: gdal_translate -of AAIGrid out.vrt out.asc
  7. out.asc will be in the correct format for the hub

If you are on Mac, please check this link for installing gdal installation - Installing GDAL on MacOSX? - Geographic Information Systems Stack Exchange

1 Like

Thanks, @vico.

I have a Macbook, so installed Gdal using Homebrew ( Following the instructions above, though, seems to have worked. Certainly, the model uploaded and displays as a faint blue square per the FAQ for Mission Hub. I can’t test it out until it stops raining and the wind drops!

Thanks for providing an Open Source solution with clear steps.

If it’d help anyone to have more step by step instructions (if you’re not familiar with working on the command line, for instance), drop a message below. :slight_smile:

Hello Vico, thanks for this solution. Is there a way in QGIS for people who don’t master the command lines? That is, can it be done in the graphical interface? Thank you so much.