Transmission frequency keeps switching to 2.4ghz

Hi to all . This is my first time at the forum . My question is about transmitting frequency. I am using Samsung Android device with mini SE and I live in California so Fcc model. When I go to transmission setting to set to manual at 5.8 ghz mainly because I am using yagis . It’s shows it switching to 2.4ghz seemingly everytime I change it close that particular settings page . So when I go back it’s always at 2.4ghz. To my understanding didn’t think FCC model even supported it. Any insight to what the deal is would be kindly appreciated

In the DJI Fly app, after you switch ‘Chanel Mode’ to ‘Manual’, you also have to pick (tap on) the desired channel (the bars below).
When you select another channel in the 5.8GHz band (numbers above 100), you get a message: “Switching channels will automatically restart Wi-Fi” now you can click ‘Cancel’ or ‘OK’.
Remember that the drone must be connected to the remote controller, because they both have to switch.

You can now close the DJI Fly app and run Litchi.

Right so I set manual to 5.8 in dji app then close then open litchi go to transmission set to 5.8 as well as I think 149 is what I’ve been using but then go to say way points and then back it’s on 2.4 again all with craft waiting to fly

So basically manual in both apps to 5.8 and ch 149 while everything on

I’m not aware of a Transmission Setting within the Litchi app.

It’s in the aircraft settings only comes up when linked to drone

I did some testing (Mini & Samsung S7), but I can’t see switching back to 2.4GHz after using a waypoint mission.
Even switching between the 2 Apps multiple times, the chosen channel stays active.

Huh yeah it stays when I use fly app but always says 2.4on litchi but that’s impossible I would think since the model isn’t supposed to have 2.4 I’ve gotten around 9,000 feet furthest range it’s the SE but range in crowded housing areas is not so good

I might try just deleting app and re installing it. Maybe it’s just a glitch

Does the mini have 2.4ghz available to switch from 5.8 and 2.4?

That would be nice to be able to have 2.4 for open areas and then use 5.8 for busy areas

I have the CE verion of the Mini 1 and can switch between 2.4 & 5.8 GHz.

@martin2 did you get this resolved? I am having a similar problem on the SE.
When I manually select a channel in the FLY app, it is reflected in Litchi, but not the Frequency.
As the manual channel I selected is outside of the 2.4 GHz channels, I suspect this is a bug in the Mini SE version and it is in fact using 5.8 GHz in Litchi

No resolve but I’m also assuming that it is in 5.8 since SE model does not support 2.4 I have no idea if a trramitted 2.4 signal can be picked up by craft using 5.8 just not very well or … My guess is it’s just a glitch and it’s really in 5.8

It depends on which model of the Mini SE:
Mini SE Transmission Power

@martin2 I agree
@TriBar, ooh that’s sneaky, I have the MT2SD25 (according to the label), but as I say, above I think it is a UI defect.

Goes anyone from @flylitchi want to weigh in here?