Track function not working with Android / DJI Air 2 S

With Litchi on Android and DJI Air 2S, I can select a target in track mode. However, when I start tracking on that target, the video starts to oscillate around with increasing amplitude, until litchi loses the target. Looks like a wrong sign in the feedback loop. This behaviour is independent of the target type and seems also to be quite independent of the distance to the target.

Same problem with my Mavic Air 2 with Litchi.
Partial Workaround: Use DJI Fly for tracking, will work much better than litchi :slightly_smiling_face:

1 Like

Thanks for confirming that I am not the only one with this problem. Sure, I used DJI Fly as a work around. However, DJI Fly limits me to persons or vehicles, but I would like to track my dog :wink: , which DJI Fly does not recognize as a valid target.


Exactly the same for me, I also wanted to try to track my dog, it did the same thing as yours, yaw oscillations, side to side, weird noises from the motors were heard, I tried to track me (thinking that maybe it doesn’t know how to track a dog) but still, same thing

Would be fine if people who managed to use Litchi’s Track function successively could mention the configuration they are using (Which Smartphone, which Litchi App, which DJI Air 2S Firmware), since Litchi mentions that a powerful Smartphone is required but don’t list devices that are sufficient.

I am using DJI Air 2 S with Firmware V02.04.2150, an Sony Xperia xZS Smartphone (G8232) with Androis 8.0.0 and Litchi Version 4.23.0-g

I do not think that it depends that much on the phone. I tried a Samsung A50 and Pixel 4, both same exact result.
What I think is causing this effect is the Advanced “Gimbal” settings. In DJI Fly, Advanced Gimbal Settings do not only affect the gimbal, but also the Yaw. And Litchi expects the drone to turn more slowly than it does, so it overshoots every time.
I would try tracking with DJI Fly Advanced Gimbal Settings reset before the flight.
I’m not going to test it because I have my Advanced Gimbal Settings tuned to custom values, and I don’t want to reset or mess with them because I do a lot of video recording and don’t do tracking.

The Active Track will not track me on my Can Am Spyder either, it does not recognize the setup as a car, and only hold me as a person for ten seconds, once it can’t “categorize” me, it drops me. I am testing my Mini 2 today to see if I am getting past the issue with Litchi. This is great software so far…

Zdravím Vás, dejte vědět jak jste dopadl s MINI 2 a režimem ACTIVE Track. Můj mini 2 ho nezvládá, mám telefon Blackview 9900. Vydrží sledovat pár vteřin a pak mě ztratí… Uvažuji o výkonnějším telefonu, ale nejsem si jistý zda to pomůže.
díky za info :slight_smile:

1 Like