This is typical Apple; recorded a flight with Litchi, click on save to files but no permission

I hope this is simple to get solved, but for me new to Apple it is not. Verified if Litchi has a setting in the menu of my iPhone that it allows it to write a recording in Albums, but can’t find it. If I want to save to files, the only folders shown are DJI FLY (and submaps that I can’t reach once placed in there) or another app’s folder that does not serve me. Still got the file open on my Litchi app, waiting for it to be saved but the general place to do that “Albums” is not in the list of choises! Now what?

Litchi - Sttings - Camera - Cache videos - on. But this is not full HD videos. And on iphone Settings - Litchi - Photos - set All Photos.

Full HD videos you can download from aircraft through DJI FLY app.

Thanks for reacting Alan, highly appreciated!
My settings were okay after all, it had saved multiple copies of my screen-recording on my iPhone and created submaps in the Album folder, but I tried so hard storing the recording in several ways, every time Litchi came back with the question bar in top of the screen (cancel or store), from which I drew the conclusion it did not succeed in previous store location. After all, it did. Weird.
iPhone settings for the Litchi app are extensive, the section camera has 2 choises related to this issue “cache videos” and “cache photos” so I enabled them although not really necessairy it seems.
I’ll try again, the Litchi app needs studying from my part, certainly now I’ve combined it with which lifts the possibilities to endless!!! :laughing: